playMaker

Author Topic: Mote Towards camera object not working[SOLVED]  (Read 1336 times)

jermerqua

  • Playmaker Newbie
  • *
  • Posts: 28
Mote Towards camera object not working[SOLVED]
« on: March 17, 2018, 10:33:26 PM »
Im following this simple tutorial
on how to create a character and am having a hell of a time getting a simple 3rd person camera to work. I'm fairly new so figure human error but MAN how frustrating. heres what I do...

a) Create empty object, name it "camera follow" and place in main character
b) Create an empty object called "camBase and place main Camera inside
c) Add FSM to camBase and add "move towards" from action browser
d) Target "Camera follow"
e) Press play > move character and camera just stands still.

I am at an absolute loss. Is there something I am missing.

In case curious here's file
https://www.dropbox.com/s/b9nri8gbw8wcjgk/Playmak_Anim_Test3.zip?dl=0
« Last Edit: March 19, 2018, 03:21:06 AM by jeanfabre »

jermerqua

  • Playmaker Newbie
  • *
  • Posts: 28
Re: Mote Towards camera object not working
« Reply #1 on: March 17, 2018, 10:52:18 PM »
Ok... So I just figured out that the 'finish distance' has to be set to 0.Makes sense.

BUT NOW I have the camera follwoing but i swear it looks more jagged... like aliased and the movement seems kind of rough. Not like when you just throw a stationary camera in the scene... you know what I mean?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15501
  • Official Playmaker Support
Re: Mote Towards camera object not working
« Reply #2 on: March 19, 2018, 03:20:56 AM »
Hi,

yes, MoveTowards doesn't use lateupdate, and it mandatory for camera control.

Use MoveTowardsAdvanced from the Ecosystem and make sure you select LateUpdate for its frame execution.

 Bye,

 Jean

jermerqua

  • Playmaker Newbie
  • *
  • Posts: 28
Re: Mote Towards camera object not working[SOLVED]
« Reply #3 on: March 20, 2018, 02:52:37 PM »
I can't find this "moveTowardsAdvanced" action that you are referencing... Is it somewhere other then the 'action browser'?

jermerqua

  • Playmaker Newbie
  • *
  • Posts: 28
Re: Mote Towards camera object not working[SOLVED]
« Reply #4 on: March 20, 2018, 03:05:45 PM »
Ok. Just learned what 'ecosystem' is which is kind of cool. Can't wait to dive in and learn other custom actions.

https://hutonggames.fogbugz.com/default.asp?W1181

Thanks for the hookup. Diving in now to see if this fixes the jitter.