playMaker

Author Topic: Touch-end events problem  (Read 615 times)

QueenM56

  • Junior Playmaker
  • **
  • Posts: 55
    • View Profile
Touch-end events problem
« on: July 04, 2018, 09:28:23 PM »
Hi All,

I'm working on a 2D mobile game and come across some problem with touch control.
I've installed CF2 and using its control rig, the problem is the all the button delays.
I've written to CF2 supplier and here is their replay:

"From time to time a strange problem pops up where Unity fails to process touch-end events resulting in frozen touches.
CF2 deals with it by automatically ending touches that aren't updated for more than certain amount of time (2 seconds by default).

Please import the attached script and add it to any non-disabled game object in your gameplay scene - it will display the number or active system touches and touch markers on the screen. If you notice touch markers remaining on the screen longer than they should, bad luck. The only solution to this bug is to create an new project and import all the assets from the old one (and hope for the best)"


Most likely I'm having this frozen touch issue, but I really don't want to restart the project as I've been doing it for 4 months.
I'm wondering if there is any other solution I can deal with it.

Hope someone here could help.

Thanks!
M

Broken Stylus

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: Touch-end events problem
« Reply #1 on: September 21, 2018, 01:18:21 PM »
Perhaps you can export all your assets as one package and then start a new project as they say, then import the package? See what happens...

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 4106
    • View Profile
    • jinxtergames
Re: Touch-end events problem
« Reply #2 on: September 22, 2018, 03:35:08 AM »
Hi.

1st make sure you have a backup.
Then make a new project.
Then open both projects and place them side by side.
Drag and drop everything (preferable folder by folder)
from the old project window to the new project window.
You might get some errors when not everything is moved yet, but they should be gone when everything is moved.

And try if the issue persists on the new project.