playMaker

Author Topic: seemingly non-functioning actions [SOLVED]  (Read 710 times)

Doh

  • Full Member
  • ***
  • Posts: 124
    • View Profile
seemingly non-functioning actions [SOLVED]
« on: November 15, 2018, 04:48:14 AM »
I've got a weird problem at the moment. I was trying and trying to get the "get signed angle to target" action to work, though it wouldn't return a value at all, it would just stay at zero no matter how I positioned/rotated the objects involved. Then I added another action to the state in an attempt to find something that would respond. On the simple presence of the extra action, they all came to life. I really don't understand this at all. Could someone more knowledgeable shed some light on this please? Or have I found a bug?

I've included a spliced together screen shot to show what happened. The extra action isn't even set up, just present. The left column is how I'd set it up initially with just the required actions, the middle column is with the extra action and the right column is like the middle column but with the extra action disabled.
« Last Edit: November 19, 2018, 06:32:53 AM by Doh »

Doh

  • Full Member
  • ***
  • Posts: 124
    • View Profile
Re: seemingly non-functioning actions
« Reply #1 on: November 15, 2018, 04:56:17 AM »
Forgot to mention I'm on Unity 2017.3.0f3 and Playmaker 1.9.0.p4

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 4459
    • View Profile
    • jinxtergames
Re: seemingly non-functioning actions
« Reply #2 on: November 15, 2018, 11:07:32 AM »
Hi.

Do you use collaborate?
FOR HIRE:Playmaker/C#

Playmaker Samples <-------------> Easy Exporter <---------------------> TPA Actions

Doh

  • Full Member
  • ***
  • Posts: 124
    • View Profile
Re: seemingly non-functioning actions
« Reply #3 on: November 15, 2018, 12:54:06 PM »
Hey Djaydino, no I don't, I had to look it up just now to find out what it was.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14400
  • Official Playmaker Support
    • View Profile
Re: seemingly non-functioning actions
« Reply #4 on: November 15, 2018, 10:46:41 PM »
Hi,

 that could be explained if your playmaker install got corrupted, for example if you don't have "PLAYMAKER_1_8_5_OR_NEWER" as scripting define symbol in your player settings configuration.

 Can you double check?

Bye,

 Jean

Doh

  • Full Member
  • ***
  • Posts: 124
    • View Profile
Re: seemingly non-functioning actions
« Reply #5 on: November 16, 2018, 12:02:41 PM »
Hey Jean, just checked and my Playmaker related ones are:

"ARRAYMAKER;DATAMAKER;ECOSYSTEM;ECOSYSTEM_0_6;ECOSYSTEM_0_6_OR_NEWER;N_3_2_0_OR_NEWER;PLAYMAKER;PLAYMAKER_1_8_5_OR_NEWER;PLAYMAKER_1_8_OR_NEWER;PLAYMAKER_1_9;PLAYMAKER_1_9_0;PLAYMAKER_1_9_OR_NEWER;PLAYMAKER_UTILS;PLAYMAKER_UTILS_1_4_OR_NEWER;"

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14400
  • Official Playmaker Support
    • View Profile
Re: seemingly non-functioning actions
« Reply #6 on: November 19, 2018, 01:21:09 AM »
Hi,

 ok, you have it.

I would try to install PlayMaker again ( just run through the installer, not need to delete anything), and make sure you have the latest as well.

 Maybe you could share the project ( pm me), I'll have a look.

Bye,

 Jean

Doh

  • Full Member
  • ***
  • Posts: 124
    • View Profile
Re: seemingly non-functioning actions
« Reply #7 on: November 19, 2018, 06:02:59 AM »
Hey Jean,

I re-downloaded Playmaker and installed it again over the top of the existing installation as you suggested though the problem still persisted.

I just updated the action in question over the ecosystem and the problem seems to have gone now.

I should have tried this earlier, I had looked and it wasn't highlighted on the ecosystem as needing an update.

Sorry for wasting your and djaydino's time!

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 4459
    • View Profile
    • jinxtergames
Re: seemingly non-functioning actions [SOLVED]
« Reply #8 on: November 19, 2018, 07:13:52 AM »
Hi.
No problem.
You are not wasting our time btw ;)
FOR HIRE:Playmaker/C#

Playmaker Samples <-------------> Easy Exporter <---------------------> TPA Actions

Doh

  • Full Member
  • ***
  • Posts: 124
    • View Profile
Re: seemingly non-functioning actions [SOLVED]
« Reply #9 on: November 19, 2018, 07:33:07 AM »
Thanks djaydino, you're a goodun!