playMaker

Author Topic: Latest 1.9 does not work with 2018.2.2 - BadImageFormatException  (Read 487 times)

acknickulous

  • Playmaker Newbie
  • *
  • Posts: 12
    • View Profile
Due to my problems building with Playmaker in 2018.3, I rolled my project back to 2018.2.20f1. But the latest version of Playmaker 1.9 does not work with this version. I tried fully deleting Playmaker and re-installing to no avail: I get a constant flow of errors in the console and none of the editor windows work (the third error repeats forever):

BadImageFormatException: Could not resolve field token 0x04000259, due to: Could not load type of field 'HutongGames.PlayMakerEditor.FsmEditor:prefabTypeLastUpdate' (42) due to: Could not resolve type with token 0100009e (from typeref, class/assembly UnityEditor.PrefabAssetType, UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null) assembly:UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null type:UnityEditor.PrefabAssetType member:(null) signature:<none> assembly:C:\Users\Flarb\Documents\Unity\DEMON'S TILT (1) - REVERT\Assets\PlayMaker\Editor\PlayMakerEditor.dll type:FsmEditor member:(null) signature:<none>
HutongGames.PlayMakerEditor.BaseEditorWindow.OnEnable () (at C:/Projects/Playmaker_1.9.0/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/BaseEditorWindow.cs:43)
UnityEditor.EditorWindow:GetWindow()
HutongGames.PlayMakerEditor.FsmEditorWindow:OpenWindow(String) (at Assets/PlayMaker/Editor/FsmEditorWindow.cs:40)
HutongGames.PlayMakerEditor.FsmEditorWindow:OpenWindow() (at Assets/PlayMaker/Editor/FsmEditorWindow.cs:26)
PlayMakerMainMenu:OpenFsmEditor() (at Assets/PlayMaker/Editor/PlayMakerMainMenu.cs:19)

TypeLoadException:Could not find method due to a type load error
UnityEditor.EditorWindow:GetWindow()
HutongGames.PlayMakerEditor.FsmEditorWindow:OpenWindow(String) (at Assets/PlayMaker/Editor/FsmEditorWindow.cs:40)
HutongGames.PlayMakerEditor.FsmEditorWindow:OpenWindow() (at Assets/PlayMaker/Editor/FsmEditorWindow.cs:26)
PlayMakerMainMenu:OpenFsmEditor() (at Assets/PlayMaker/Editor/PlayMakerMainMenu.cs:19)

TypeLoadException: Could not find method due to a type load error
System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at <f2e6809acb14476a81f399aeb800f8f2>:0)
Rethrow as TargetInvocationException: Exception has been thrown by the target of an invocation.
System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at <f2e6809acb14476a81f399aeb800f8f2>:0)
System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) (at <f2e6809acb14476a81f399aeb800f8f2>:0)
UnityEditor.HostView.Invoke (System.String methodName, System.Object obj) (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:295)
UnityEditor.HostView.Invoke (System.String methodName) (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:288)
UnityEditor.HostView.OnFocus () (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:119)
UnityEditor.EditorWindow:GetWindow()
HutongGames.PlayMakerEditor.FsmEditorWindow:OpenWindow(String) (at Assets/PlayMaker/Editor/FsmEditorWindow.cs:40)
HutongGames.PlayMakerEditor.FsmEditorWindow:OpenWindow() (at Assets/PlayMaker/Editor/FsmEditorWindow.cs:26)
PlayMakerMainMenu:OpenFsmEditor() (at Assets/PlayMaker/Editor/PlayMakerMainMenu.cs:19)



Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3632
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Latest 1.9 does not work with 2018.2.2 - BadImageFormatException
« Reply #1 on: January 05, 2019, 09:35:37 PM »
Hi, it looks like Unity is still trying to use the version of PlayMaker for 2018.3. There is an Asset Store bug that uses the last version downloaded even if it's not for the version of Unity you're currently running. You have to manually update PlayMaker in the Asset Store while running 2018.2 to get the correct version (then import and install).

We're looking into a workaround for that Unity build bug in 2018.3. Should hopefully have a fix soon...
« Last Edit: January 05, 2019, 09:41:12 PM by Alex Chouls »

acknickulous

  • Playmaker Newbie
  • *
  • Posts: 12
    • View Profile
Re: Latest 1.9 does not work with 2018.2.2 - BadImageFormatException
« Reply #2 on: January 05, 2019, 09:40:37 PM »
How do you manually update? I tried deleting the folder and re-installing to no avail. Do I have to blow away the downloaded cache somewhere?

Also what timeline is "soon" on 2018.3 support? I'd love to upgrade to 2018.3 ASAP.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3632
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Latest 1.9 does not work with 2018.2.2 - BadImageFormatException
« Reply #3 on: January 05, 2019, 09:44:52 PM »
Yeah, you need to update the Asset Store cache. I switch to the old Asset Store UI, go to downloads, find the asset and update/download. I remember the new Asset Store UI being buggy, but they might have fixed that...

I'm trying to get more details on the build bug from Unity. I'd love to get it fixed asap!

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14572
  • Official Playmaker Support
    • View Profile
Re: Latest 1.9 does not work with 2018.2.2 - BadImageFormatException
« Reply #4 on: January 08, 2019, 02:23:49 AM »
Hi,

 yes, this is really a pain :) also, a quicker way is to locate the assetStore cache folder on your hardrive and directly delete it here, the old Asset Store UI takes ages to get that process done, while if you have a shortcut to the folder directly, it's quicker.

https://forum.unity.com/threads/asset-store-download-folder.83620/

Bye,

 Jean