playMaker

Author Topic: Android App Bundle error on an unchanged game [SOLVED]  (Read 454 times)

bazzajunior

  • Playmaker Newbie
  • *
  • Posts: 25
    • View Profile
    • Molber Games
Android App Bundle error on an unchanged game [SOLVED]
« on: May 30, 2019, 06:00:27 AM »
After receiving a warning about having to update my app from 32 to 64 bit for inclusion on the Google Play Console, I took the necessary actions in Unity's Player Settings (IL2CPP and ARM64) and exported the app out using Gradle (I have to remove certain permissions from the Android Manifest that can't be done any other way) and built a new Android App Bundle (aab) in Android Studio.

The aab uploaded fine into a new Beta release and passed all the necessary checks on the Google Play Console, but upon starting up the game on my Pixel 2, the game's touch movement system doesn't work.

The movement system, which consists of a detect touch (TouchEvent) to start the wheel motor torque of a tank and then track the user's finger on the screen to rotate to its location, hasn't been altered in any way and worked fine following an APK update last week.

Now, the game tracks the user's finger and rotates the tank but the motor torque doesn't appear to be doing anything.

I'm baffled by this as nothing's changed but the aab is obviously messing with something that an apk didn't have an issue with.

Has anyone else noticed any odd changes since the roll out of the aab option?
« Last Edit: August 16, 2019, 07:05:01 AM by bazzajunior »

RDroste

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
Re: Android App Bundle error on an unchanged game
« Reply #1 on: July 12, 2019, 04:46:00 AM »
I'm not sure if this will be applicable to your situation, but I had a similar problem for the exact same reason (Google not supporting the 32 bit builds). When switching my project to the IL2CPP back end scripting my set property action didn't work.

I remembered that WebGL had a similar problem and was fixed with the linker wizard found in the ecosystem.

here is the link to the discussion on the linker wizard: https://hutonggames.com/playmakerforum/index.php?topic=11126.0

I tried that and worked like a charm, so might be something to look into.