playMaker

Author Topic: Ecosystem 0.6.8 Bad Credentials error[PENDING FIX,TEMPORARY FIXED]  (Read 111 times)

WabbysLand

  • Playmaker Newbie
  • *
  • Posts: 23
    • View Profile
I can't use Ecosystem anymore. When searching for actions there is a red alert :

Bad credentials. The API can't be accessed using username/password authentification. Please create a personal access token to access this endpoint : http://github.com/settings/tokens

---

So I tried to create a personnal token on github but that nos solves the issue

Same error on Unity 2018 or 2019 in a fresh project
« Last Edit: October 28, 2020, 11:27:19 PM by jeanfabre »

HAIRGROW

  • Playmaker Newbie
  • *
  • Posts: 21
    • View Profile
Re: Ecosystem 0.6.8 Bad Credentials error
« Reply #1 on: October 28, 2020, 10:57:32 AM »
I'm having the same exact issue as well. Just did a forum search for a resolution and come across this post.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15403
  • Official Playmaker Support
    • View Profile
Re: Ecosystem 0.6.8 Bad Credentials error
« Reply #2 on: October 28, 2020, 01:17:47 PM »
Hi,

 yeah, this is a pain, the ecosystem is going to be down while I am switching the back end to use their new api for connecting to their systems...

Hopefully, this will go smoothly, but last time I tried I struggled, but now that they've completly removed the old way, I must get it done... hopefully, within the next 24 hours ( it's late here... so I'll get on it tomorrow morning first thing)

Bye,

 Jean

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15403
  • Official Playmaker Support
    • View Profile
Re: Ecosystem 0.6.8 Bad Credentials error[PENDING FIX,TEMPORARY FIXED]
« Reply #3 on: October 28, 2020, 11:30:09 PM »
Ok,

 Github renabled the current auth system until nov 13th, so I'll have time to figure it out. though last time I tried, I could not make it work.. maybe the docs will be clearer or some php sample will be available now.

Bye,

 Jean

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15403
  • Official Playmaker Support
    • View Profile
Re: Ecosystem 0.6.8 Bad Credentials error[PENDING FIX,TEMPORARY FIXED]
« Reply #4 on: November 04, 2020, 11:47:19 AM »
Hi,

 so, I updated to a different oAuth system and hopefully, this is ok, but I can only know when the system is stressed with a hight query rate, so if you get some red warning UI telling you the api query rate limit has been hit, let me know. it should not.

Github has made it more difficult to provide a service using their REST API such as the one I provide for the PlayMaker Ecosystem, the alternative would be to make a two step auth system.. needless to say it's not acceptable due to the context in which we use this... I may be missing something though, their doc is cripcit, and full of deprecated feature mixed with blurry vocabulary, very difficult to find your way around it unfortunatly.

So let me know if you rate limit red warnings :)

Bye,

 Jean

Christoph

  • Playmaker Newbie
  • *
  • Posts: 32
    • View Profile
Re: Ecosystem 0.6.8 Bad Credentials error[PENDING FIX,TEMPORARY FIXED]
« Reply #5 on: November 04, 2020, 07:39:27 PM »
Hi Jean,

I got the warning API query rate limit has been hit several times today. Right now it seems to be good though.

Cheers!