playMaker

Author Topic: Prefab/send event/ add force?  (Read 2010 times)

eccoecco

  • Playmaker Newbie
  • *
  • Posts: 19
    • View Profile
Prefab/send event/ add force?
« on: September 22, 2012, 09:08:29 AM »
Hey,
I've been using playmaker for a while now but I'm get stumped on what I'm sure is a simple issue.  I'm trying to get a black ball (prefab) to have force added to it when it touches (trigger event) the red bar.  The red bar sends a send event to the black ball's fsM state (shown) "add force to self" which wil lead into state2 where the add force action is shown.  Although the red bar acknowledges the interaction and travels through it's state machines (I assuming trying to send the event to the black ball), the black ball's fsm never moves from State 1 into State 2.

Is this a prefab issue?

Sjones

  • Full Member
  • ***
  • Posts: 201
    • View Profile
Re: Prefab/send event/ add force?
« Reply #1 on: September 22, 2012, 11:56:38 AM »
use a send event to fsm instead of just a send event, this should work

eccoecco

  • Playmaker Newbie
  • *
  • Posts: 19
    • View Profile
Re: Prefab/send event/ add force?
« Reply #2 on: September 22, 2012, 07:46:38 PM »
When i use "send event to fsm" action I get this:

eccoecco

  • Playmaker Newbie
  • *
  • Posts: 19
    • View Profile
Re: Prefab/send event/ add force?
« Reply #3 on: September 22, 2012, 07:53:18 PM »
Just to clarify:
I created: sphere default and the event: "force" was made global. But when the ball travels through the trigger which is the long bar, the bar's FSM recognizes the tagged game object, it moves to the next State with the "send event" with the sphere default's FSM and global event targeted, but nothing happens.

I'm sure this is something real easy but I'm going to kill a bunny rabbit if I can't figure out the answer.
Just saying.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14701
  • Official Playmaker Support
    • View Profile
Re: Prefab/send event/ add force?
« Reply #4 on: September 23, 2012, 11:40:13 PM »
Hi,

 You need to use the latest version of PlayMaker. Maybe the example you took was from a an old version?

Use the "send event" action then.

 If that doesn't help, make the event a global transition of the state instead of a simply transition. This might solve the problem. Are you aware of what a "global transition is?"


bye,

 Jean