playMaker

Author Topic: Enormous slowdowns when in Playmode with Playmaker opened [FIXED]  (Read 199 times)

Gua

  • Full Member
  • ***
  • Posts: 248
    • View Profile
    • Andrii Vintsevych
Unity 2018.4.30
Playmaker v1.9.1.f7

Sometimes I get enormous slowdowns when in Playmode with Playmaker in opened. I've finally was able to capture that slowdown with Profiler.

Don't know how to reproduce it. I usually need to restart Unity to fix it.

« Last Edit: January 29, 2021, 11:00:19 PM by Alex Chouls »

Gua

  • Full Member
  • ***
  • Posts: 248
    • View Profile
    • Andrii Vintsevych
Re: Enormous slowdowns when in Playmode with Playmaker opened
« Reply #1 on: January 25, 2021, 04:09:33 PM »
Do I need to provide more information regarding this. Or information that I've already provided is enough to fix it?

Gua

  • Full Member
  • ***
  • Posts: 248
    • View Profile
    • Andrii Vintsevych
Re: Enormous slowdowns when in Playmode with Playmaker opened
« Reply #2 on: January 25, 2021, 04:23:48 PM »
I've noticed that those slowdowns only happen when global tabs is present in interface.


Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3772
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Enormous slowdowns when in Playmode with Playmaker opened
« Reply #3 on: January 25, 2021, 06:01:45 PM »
Thanks, that's useful. The next patch is in beta now. It has some performance improvements.

Gua

  • Full Member
  • ***
  • Posts: 248
    • View Profile
    • Andrii Vintsevych
Re: Enormous slowdowns when in Playmode with Playmaker opened
« Reply #4 on: January 27, 2021, 05:22:43 PM »
Looks like I've see what is happening. While auto refresh on focused is off in my globals, in this example you can clearly see that while in playmode. Playmaker is trying to update usage count for playmaker global variables and this is causing those enormous slowdowns.

Start watching from 2:49

« Last Edit: January 27, 2021, 05:24:38 PM by Gua »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3772
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Enormous slowdowns when in Playmode with Playmaker opened
« Reply #5 on: January 27, 2021, 06:35:27 PM »
Thanks for the video. This should be better in p2.
I'm also adding a Debug Performance preference to log extra info on performance bottlenecks in the editor so I can get more info from your projects. This should help us track down problems quicker.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3772
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Enormous slowdowns when in Playmode with Playmaker opened
« Reply #6 on: January 29, 2021, 12:41:07 PM »
Is this better in 1.9.1p2 for you?

If not, please enable:
PlayMaker Editor > Preferences > Experimental > Debug Performance

If you see FsmSearch.UpdateAll() logged while playing the game in the editor, please copy-paste the log entry here (including the full call stack). Thanks!

Gua

  • Full Member
  • ***
  • Posts: 248
    • View Profile
    • Andrii Vintsevych
Re: Enormous slowdowns when in Playmode with Playmaker opened
« Reply #7 on: January 29, 2021, 09:48:09 PM »
Those enormous slowdowns are gone. Thanks for the fix!

There is one playmode related performance problem, but I need to do more experiments to find a way how to reproduce it.