playMaker

Author Topic: Playmaker last event exit bug.  (Read 1444 times)

softsound

  • Playmaker Newbie
  • *
  • Posts: 1
    • View Profile
Playmaker last event exit bug.
« on: April 17, 2014, 04:16:25 PM »
Hi,

I'm having a bit of trouble.

I'm unable to exit the "last event" in playmaker.
By last event, I mean the last event before this will loop.
In this case the last event is send event  set to "finished".

Click to see bigger version.

This shows send event is working and is setup exactly like the "last event".


This shows how the last event is setup.


See the bug in action on youtube. -> http://youtu.be/ceHCry14VrM

The "finished" transition of send event is connected to the start of the loop but since the event never exits, I'm unable to return to the start of the loop, it just stays at the last event, which is annoying as I'm trying to create a loop where this object moves around randomly.

The event itself is not the problem, as I've been able to prove send event worked earlier in the state machine, I've had this issue with other events, but only in this scene and I want to know why. There are no other objects in the scene with scripts, or playmaker events. I do not get any error messages, the game just keeps running, as you will notice the timer at the bottom has been changing.

I've had some luck deleting the "last event" and recreating it but it only works sometimes. As of late my attempts to delete and recreate the event have not been working, playmaker still will not exit the send event....

I've tried triggering off and on the every frame bool because I think that might sometimes help, but I'm not sure why some send events must be set to every frame in this scene to run and even then, I've had issues.

I am running Unity 4.3.2f1 and playmaker version 1.5.4 if that will help with the investigation.

My bug tracking ticket is 987_fpj8t00h64aip9q3, I apologize as I was not sure how to apply more information to my bug report.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15489
  • Official Playmaker Support
    • View Profile
Re: Playmaker last event exit bug.
« Reply #1 on: April 25, 2014, 08:34:53 AM »
Hi,

 first, you should not manually send the event "FINISH", it's a special event that should be left alone.

 Create your own local event "DONE" or something and fire that, things will get clearer and less prone to unpredictable behavior.

then I am really confused by your logic, you don't need to use "everyframe" on this send event ( I NEVER use everyframe on the sendevent action myself).

 Bye,

 Jean