playMaker

Author Topic: Cut to Camera bug?  (Read 3887 times)

motiondisabled

  • Playmaker Newbie
  • *
  • Posts: 5
    • View Profile
Cut to Camera bug?
« on: October 17, 2011, 07:34:15 AM »
Hi when i try and use the Cut to Camera it doesn't work.

All i want is for a camera to use itween to follow an animated object and then to changed to another camera which does the same thing with another object. while using fade in and out during the transitions.

This seems simple and i can get every thing to work until it come to changing the camera it just freezes the camera it's on.

please help
« Last Edit: January 18, 2015, 11:30:52 PM by jeanfabre »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3582
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Cut to Camera bug?
« Reply #1 on: October 17, 2011, 07:49:43 AM »
The old camera is probably not getting disabled, and is still rendering on top of the new camera. Try disabling all cameras in the editor before running the game, and let Cut To Camera turn each one on as needed.

I need to make another pass on the camera actions to make them more user friendly...

Satrio

  • Junior Playmaker
  • **
  • Posts: 67
    • View Profile
Re: Cut to Camera bug?
« Reply #2 on: March 28, 2013, 05:19:35 AM »
to clarify, disable the camera component, not the entire gameobject.

SpencerPDX

  • Playmaker Newbie
  • *
  • Posts: 22
    • View Profile
Re: Cut to Camera bug?
« Reply #3 on: November 18, 2013, 02:20:12 AM »
Thanks a ton for these last two suggestions, they finally solved this problem that had been bugging me for months. I had been getting around it by turning off all other cameras but the one I was switching to - a little awkward to say the least!

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14062
  • Official Playmaker Support
    • View Profile
Re: Cut to Camera bug?
« Reply #4 on: November 18, 2013, 10:56:07 PM »
Hi,

 Who is "they"? Unity?

bye,

 Jean

Patti64

  • Playmaker Newbie
  • *
  • Posts: 1
    • View Profile
Re: Cut to Camera bug?
« Reply #5 on: May 04, 2014, 04:46:21 AM »
I'm brand new to Playmaker and was follow your beginner tutorial on Camera Cuts (http://www.hutonggames.com/tutorials_camera_motion_and_control.php)
and have been up all night trying to make this work!! Possibly you should remove that tutorial??

In any case, can you please clarify how I can "turn off the camera component (not the game object) so that I can make this work?"

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14062
  • Official Playmaker Support
    • View Profile
Re: Cut to Camera bug?
« Reply #6 on: May 06, 2014, 04:48:01 AM »
Hi,

 whwre do you enconter problem in this tutorial? at what point precisly?

To turn off a camera component, use "enable Behavior", then "camera" will be listed if you point to the camera gameobject.


bye,

 Jean

SirGatlin

  • Playmaker Newbie
  • *
  • Posts: 17
    • View Profile
Re: Cut to Camera bug?
« Reply #7 on: January 11, 2015, 09:08:39 PM »
ok, yeah I was having the same issue with the layering, but now that I understand the issue I am curious to why even use Cut To Camera and not Just enable behavior to enable and disable the cameras?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14062
  • Official Playmaker Support
    • View Profile
Re: Cut to Camera bug?
« Reply #8 on: January 18, 2015, 11:30:06 PM »
Hi,

 It's simply a convenient action that switches two camera on and off, so yes, you can  do it all manually.

Bye,

 Jean