playMaker

Author Topic: Unity 4.6 - Warning message  (Read 2145 times)

jess84

  • Hero Member
  • *****
  • Posts: 506
    • View Profile
Unity 4.6 - Warning message
« on: September 12, 2014, 11:14:47 AM »
Quote
Assets/PlayMaker/Editor/PlayMakerGUIInspector.cs(26,26): warning CS0618: `UnityEditor.EditorGUIUtility.LookLikeInspector()' is obsolete: `LookLikeControls and LookLikeInspector modes are deprecated.'

What do I need to change to stop getting this warning?

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3634
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Unity 4.6 - Warning message
« Reply #1 on: September 12, 2014, 02:01:08 PM »
Open PlayMakerGUIInspector.cs and change:

#if UNITY_4_3 || UNITY_4_5

to:

#if UNITY_4_3 || UNITY_4_5 || UNITY_4_6

This will also  be in the next update.

jess84

  • Hero Member
  • *****
  • Posts: 506
    • View Profile
Re: Unity 4.6 - Warning message
« Reply #2 on: September 12, 2014, 08:38:32 PM »
Great, thanks.

I was actually surprised it was just one warning in total, and no errors  :)