playMaker

Author Topic: No Finish Event logic works  (Read 1314 times)

mweyna

  • Full Member
  • ***
  • Posts: 242
    • View Profile
No Finish Event logic works
« on: March 11, 2015, 12:23:26 AM »
For some reason, my playmaker simply stopped responding to any WAIT defined anything in any FSM project wide and I'm stumped as to why. It will simply hang on those actions and not finish. No errors reported, any this seems to affect any Playmaker action with a defined Finish Event. I've tried in both the latest and previous version of playmaker, and running 4.6. I've tried importing my entire project into a new scene. I've tried removing playmaker entirely and installing a clean version. None of these seem to work. Anyone have any ideas?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Re: No Finish Event logic works
« Reply #1 on: March 12, 2015, 10:57:49 PM »
Hi,

 Have you changed the time settings somehow? maybe your game is paused with a time of 0

Bye,

 Jean

mweyna

  • Full Member
  • ***
  • Posts: 242
    • View Profile
Re: No Finish Event logic works
« Reply #2 on: March 12, 2015, 11:26:27 PM »
Nope, all the values are still default. I've managed to revert back to a slightly older scene file and everything seems to work, although I'd lose about a week of work or so.

mweyna

  • Full Member
  • ***
  • Posts: 242
    • View Profile
Re: No Finish Event logic works
« Reply #3 on: March 13, 2015, 12:14:54 AM »
I've managed to Frankenstein my project back together, still no clue what caused the bug to happen in the first place though.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Re: No Finish Event logic works
« Reply #4 on: March 18, 2015, 01:18:35 AM »
Hi.

 yeah these things happens.. Are you using github? this makes solving this kind of problem very easy ( reverting to an older version to double check, without loosing current work, etc).

 Bye,

 Jean