playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - qholmes

Pages: [1] 2 3 ... 6
1
Hello,

I have been out of the loop for a bit. And i have a few potential project i need to get started on. I have been reading all the Beta posts and was wondering what the new features are doing to help with workflow or have changed the workflow. I last used the Asset store version of January 2013 i think..
Here are a few things i got from Alex:

- Improved Get/Set Property actions now lets you drill down into properties.
- You can specify a Template to use in the PlayMakerFSM inspector.
- The Run FSM action lets you run a Template as an FSM.

The new template stuff lets you make re-usable FSMs. Edit the template and it's updated wherever it's referenced.

I will have to research some of these things some more to see how they would effect my work flow.

Also I am not sure what i would do with CustomActionEditors and ObjectProperty Drawers.. if anything.. maybe just for 3rd party people for the most part..

Anyway if you have anything specific you have used and would like to share that would be cool thanks

Q

2
General Discussion / Colliders on Parents
« on: January 24, 2013, 12:39:42 PM »
Does anyone have a cool way of creating a simple box collider on a Parent object when all the meshes are in its children?
As it is i have to manually set up my box colliders.. not a huge deal but was hoping for a better way.

Q

3
Playmaker Help / Screen Pick[SOLVED]
« on: January 23, 2013, 10:17:13 PM »
I am using the Screen Pick action.. modified. But i can not get the action to give me a GO reference. I even tried the unmodified one and still nothing?

I get the position and distance etc.. i have it set up to send events etc. Everything works except for the GO reference.

Q

4
Playmaker Help / Templates not work?[SOLVED]
« on: January 22, 2013, 01:32:54 PM »
I just made some new templates on my Mac and copied them over to my PC to a new project and they come in blank... now my older Templates that i also copied over work fine?

Q

5
General Discussion / Custom Editor Layouts die
« on: January 21, 2013, 09:16:01 AM »
Has anyone had problems getting saved Unity Editor layouts  to work?

I have always had this problem for the past 2 years. On both  my Mac and PC work stations. I just installed a brand new Unity 4 on my PC for the first time.... nothing in the project except PlayMaker and EZ Gui and SM2.

Those are the editor windows i use in my layouts... and it seems to die every time i restart Unity.. I had it working so that i could switch between layouts but when i restarted it is just junk.... with lots of Failed to Destroy View errors..

I am so sick of rebuilding the editor layoutsl....

So anyone else have this issue and maybe some hints or something?

Thanks

Q

6
General Discussion / New PM or not
« on: January 18, 2013, 02:34:58 PM »
So i am trying to get a demo out using Unity 3.5. I have not upgraded to 4 yet because i am waiting for a sign off on a big project and dont want to get into upgrading issues at this point. I think that makes sense.

For all i know i can run both versions but i dont know how.

I just totally screwed my project so i am trying to rebuild from an older copy.... But is the PM from the Asset store compatible with Unity 3.5?

I installed it and now i dont have a PM menu at the top and for some reason i lost all my layouts i had to Factory Reset them so now i cant get my editor windows back. In the middle of a bit of a melt down actually. :'(

So do i have to remove the old PM? and re install?

How do you even remove an Asset from a project? There does not seem to be a clean way.... or i just dont know what i am doing. which is quite possible.

Any help would be much appreciated.

Q


7
Playmaker Help / Create Object FSM issue
« on: January 07, 2013, 07:18:36 PM »
So i am sure this is something i am doing wrong... I am working on my conveyor system so i am creating parts to travel along it.. I have never used the Create Object action before...

I have my main Part object.. It is a prefab. It gets to a point and it creates a new copy of the same Prefab... The FSM logic comes in at the same point as the first one instead of starting where it should?

Do i need to create all the Prefabs from a separate object? That is what i am going to try right now.

Q

8
Playmaker Help / Load Level and out of memory
« on: December 21, 2012, 12:50:00 PM »
Why do i constantly get Out of Memory errors when i Load Level.. Does the PM Load level not work properly by flushing the old Level?

It works fine on my iPad.. But in Editor it does not.. I dont set any of the radio buttons.. on the action. Just the Level Name.

Q

9
General Discussion / Conveyor Belt Track system
« on: December 18, 2012, 12:54:55 PM »
I was wondering if anyone had some good ideas on how to build a conveyor belt type simulation system using PM?

I have a few ideas but have not put any of them in motion yet. I am currently busy finishing up some 3DS Max stuff first. But this will be pressing when i am done. So thought i would throw out the question now.

So the question is: if you picture an automation type scenario with instrument type stop locations and small pieces of conveyor type track in between and decision making gates.. And parts have to move around on it and queue up if things get backed up etc..

I have been out of Unity for a few months so am having a bit of a struggle figuring out how to set up track sections with decision logic on them and how to trigger that logic with my objects moving around.

Maybe the toughest job will be the queuing of the objects on the track..

Anyway if anyone has any ideas it would be much appreciated.

Thanks

Q

10
Playmaker Bug Reporting / Send Event Delay
« on: September 17, 2012, 01:26:51 PM »
I just found an error i think.. I have a Send Event with a 20 second delay to reset some animations kind of in a loop..

So at 20 sec it jumps to another state and then back to this one to reset the animations and other things to the beginning etc..

So it runs fine if i just start it up and run it.. now if i click another object that causes this FSM to jump to another state of waiting it is like the timer for the send even is messed up.. after this it now triggers after 8 to 14 seconds or something.. kind of random.

I honestly dont remember what version i am running at the moment. I have not been doing any beta testing that i know of.. so probably just the latest stable normal release.. Unless there is a new one lately which i have not updated to..

11
General Discussion / Play certain animation[SOLVED]
« on: August 03, 2012, 10:14:59 AM »
Ok i just cant seem to get this to work..

Using Playmaker actions... how do i play a certain animation.. i am not blending animations it is a mechanical project... So some objects have say 3 different animations  on them for different scenarios.. so i might click on the object itself and it plays a simple animation #1 but if i click on a button it might play a different one..

I did not know i had a problem but have been adding animations to objects.. I normally just set the time on them and the speed. I thought it was switching between them but it is not. I run an animation in one state and then when i exit i set the time and speed in another state to another animation.... but it just sets the time for the current animation instead of the new one... maybe it is blending it or something.. not sure.

I know that is a confusing paragraph to read but it is basically what is going on.. How can i play one animation file then switch to a totally different one? set layers or weights? i have tried. i think.. unless i am going about it the wrong way?

Q

12
General Discussion / [SOLVED]Duplicate GO
« on: May 29, 2012, 08:26:16 PM »
Ok this may be a dumb question but when i Duplicate an object how do i know what is the new one and what is the old one.. when you have an object referenced around your project and then duplicate it and manipulate it and then realize you were manipulating the wrong one you end up where i am right now... again...

Why does it not give it a new name with copy on it or something.

Q

13
Playmaker Help / Float compare big delays
« on: April 04, 2012, 01:19:25 PM »
I am having some strange issues at the moment.. I am building a kind of Cover Flow menu system so i am tracking a touch and using Float Compare.. So it seems to really hit the cpu for some reason.. I have never had this before that i know..

Strange at the moment it seems to be ok... I also have some Animate Float actions and they are running really slow too..

If i turn off this FSM it all speeds up like the FSM is bad or something.

Q

14
I use a lot of standardized FSMs and i was switch between two objects updating some values and when i would switch to the one i was copying the values to it would show the values from the one i just came from in a Float Operator i think it was.. I did a double take because i was just about to type them in to those spots and of course everything else is the exact same so it is had except for the name of the object to know what one you are on.. So i switched to my original and then back and then the values were like i thought they would be.. it happened a few times.. I have seen that issue in other Asset packages like EZ Gui too.

Q

15
If i am on an object that has an FSM and i switch to my FSM editor it just shows what was in there last not the current selected object.. I have to have the editor open and then switch to another object and then back to get it to work.

Q

Pages: [1] 2 3 ... 6