playMaker

Author Topic: 1.8 Playmaker General Preferences - Auto Load All Prefabs in Project  (Read 2839 times)

MAX_POWER

  • Playmaker Newbie
  • *
  • Posts: 24
    • View Profile
Re: 1.8 Playmaker General Preferences - Auto Load All Prefabs in Project
« Reply #15 on: January 25, 2016, 09:27:27 AM »
Disabling real time error checking from the error check preferences did help. Thanks.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3202
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: 1.8 Playmaker General Preferences - Auto Load All Prefabs in Project
« Reply #16 on: January 28, 2016, 10:02:24 AM »
There's a new version in the store that fixes editor performance issues with larger FSMs. It should also help with editing prefabs.

Import the latest version and install 1.8.0 beta 41 from the Welcome Window.

chinper

  • Playmaker Newbie
  • *
  • Posts: 13
    • View Profile
Re: 1.8 Playmaker General Preferences - Auto Load All Prefabs in Project
« Reply #17 on: January 28, 2016, 06:57:55 PM »
Great! I will give it a try. Thanks.

chinper

  • Playmaker Newbie
  • *
  • Posts: 13
    • View Profile
It has been sometime and I am using 1.8.0 beta 43, nothing has changed I still have very slow performance in both Unity and Playmaker Editor. Disable Autoload prefab in scene & real time error checking doesn't help at all.

I also realised, even with the Autoload prefab off my empty scene is still loaded with hundreds of FSM in Playmaker editor so trying to PLAY an empty scene takes more than 10 seconds.

To recreate this, just load a scene with many FSM game object, go to new empty scene. Open Playmaker Editor and you will see all the FSM object still remain in the recent list from previous heavy scene. Is there a way to clear the list so at least I can have run faster on an empty scene?

mdotstrange

  • Hero Member
  • *****
  • Posts: 549
    • View Profile
    • Can't code? Who cares! Make games anyway!
I'm also having the same issue- my scene takes 20-28 seconds to play- I tried all the Playmaker tips I could find on these forums and all the Unity tips I could find like these http://answers.unity3d.com/answers/966405/view.html but no speed up-

I tried to resolve it using Unity 5.2 - 5.4 and Playmaker 1.8.0 - 1.8.1 and implementing everything I could find but I still have the long hang before play times-

I tried deleting assets one by one to find out what asset/script was causing the delay- it wasn't just one- things gradually sped up as I deleted assets and Playmaker actions- but I can't do that with my project as I need the assets-

I also tried creating a new project adding assets one by one while timing play mode wait times- with all the assets the load time was only 3 seconds-

Anyone have any secret techniques to share?



Indie game dev and instructor at the Strange School. Learn Playmaker at the Strange School!