playMaker

Author Topic: TriggerEvent - Target Object  (Read 1478 times)

MakerPlay

  • Playmaker Newbie
  • *
  • Posts: 19
    • View Profile
Re: TriggerEvent - Target Object
« Reply #30 on: August 17, 2017, 06:40:51 AM »
Very cool  8)
This is what i wanted to hear. Possible custom-actions, new infrastructure and TargetObjects for events. Nice bright future  :)

NinjaX

  • Junior Playmaker
  • **
  • Posts: 93
  • XCO is the ULTIMATE IOS Ninja!!
    • View Profile
    • XCOGAMES
Re: TriggerEvent - Target Object
« Reply #31 on: August 26, 2017, 05:42:19 PM »
BUMP

Sorry but I need help with an ALTERNATIVE for Trigger Stay!

When you put a Trigger enter event it lets you store the results in a "GameObject Variable" How do I use this with BOOLS ?

What is the best alternative for Trigger Stay ? Thank You so much :)
XCO is the ULTIMATE IOS Ninja, Beware for he sees Everything and Nothing all at once!

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 2656
    • View Profile
    • jinxtergames
Re: TriggerEvent - Target Object
« Reply #32 on: August 27, 2017, 12:49:29 AM »
Hi,
You can use "get Fsm bool" to get the bool value from that fsm on another fsm

Then you can use a bool test to see if true or false,
then you can for example use a send event to do something

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3252
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: TriggerEvent - Target Object
« Reply #33 on: December 23, 2017, 02:24:05 PM »
The latest update includes target objects for collision and trigger actions.
Please give them a go and let us know how they work for you!

MakerPlay

  • Playmaker Newbie
  • *
  • Posts: 19
    • View Profile
Re: TriggerEvent - Target Object
« Reply #34 on: December 27, 2017, 06:55:36 AM »
Very Cool. You mean the new 1.8.6 Version ?
As i know, in v. 1.8.5 you have two versions. One for Unity 4 and another one for Unity 5. It seems in v. 1.8.6 there are some for Unity 5 and Unity 2017. Am i missing  somewhere Unity 4 ? Or will there not be anymore Unity 4 versions included ?

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3252
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: TriggerEvent - Target Object
« Reply #35 on: December 27, 2017, 05:15:14 PM »
Yes, in Playmaker 1.8.6.
Newer versions of Playmaker (1.8.6+) now need Unity 5.3+
We'll probably raise this to 5.6 soon since Unity is not patching older versions to fix issues with macOS 10.13 (High Sierra):
https://forum.unity.com/threads/unity-and-macos-10-13-high-sierra.474527/

MakerPlay

  • Playmaker Newbie
  • *
  • Posts: 19
    • View Profile
Re: TriggerEvent - Target Object
« Reply #36 on: December 27, 2017, 05:24:33 PM »
Ah ok. Good to know. Thx for clarification !