playMaker

Author Topic: Playmaker 1.8.5 doesn't work in Unity 5.6.1[SOLVED]  (Read 2130 times)

Rabagast

  • Hero Member
  • *****
  • Posts: 679
    • View Profile
    • Homepage
Playmaker 1.8.5 doesn't work in Unity 5.6.1[SOLVED]
« on: September 25, 2017, 05:21:22 PM »
Hi!
When I created a brand new project in Unity 5.6.1 and installed Playmaker 1.8.5, I got a lot of these errors:

TypeLoadException: Could not load type 'UnityEngine.ImageConversion' from assembly 'PlayMakerEditor'.
HutongGames.PlayMakerEditor.FsmEditorStyles.InitCommon () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/FsmEditorStyles.cs:1103)
HutongGames.PlayMakerEditor.FsmEditorStyles.Init () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/FsmEditorStyles.cs:1096)
HutongGames.PlayMakerEditor.FsmEditor.OnGUI () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/FsmEditor.cs:626)
HutongGames.PlayMakerEditor.FsmEditorWindow.DoGUI () (at Assets/PlayMaker/Editor/FsmEditorWindow.cs:95)
HutongGames.PlayMakerEditor.BaseEditorWindow.OnGUI () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/BaseEditorWindow.cs:72)
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)


It worked in Unity 2017.1, but then, there is a problem with Text Mesh Pro.

Does anybody else has problems with Playmaker 1.8.5 in Unity 5.6.1 and Textmesh Pro in Unity 2017.1?
« Last Edit: September 27, 2017, 10:46:45 PM by jeanfabre »
Check out our homepage. http://www.walsberg.no
Or my personal game blog for news about my games. http://retro-tetro.walsberg.no

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3306
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Playmaker 1.8.5 doesn't work in Unity 5.6.1
« Reply #1 on: September 26, 2017, 06:55:31 PM »
It seems the Asset Store is kind of buggy at managing downloads for different versions of Unity. It looks like it's trying to import the Unity 2017.1 version of Playmaker (probably the last version you downloaded) into Unity 5.6. UnityEngine.ImageConversion was new in 2017.1 so wouldn't work in Unity 5.6.

In Unity 5.6.1 make sure you go into the Asset Store download manager and re-download Playmaker. This should get you the correct version of Playmaker for the version of Unity you're using. If you've previously imported the 2017.1 version, you may need to restart Unity before and/or after downloading and importing the new version.

Rabagast

  • Hero Member
  • *****
  • Posts: 679
    • View Profile
    • Homepage
Re: Playmaker 1.8.5 doesn't work in Unity 5.6.1
« Reply #2 on: September 27, 2017, 02:52:43 PM »
Hi, Alex!
It worked! Thank you! :D
Check out our homepage. http://www.walsberg.no
Or my personal game blog for news about my games. http://retro-tetro.walsberg.no

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3306
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Playmaker 1.8.5 doesn't work in Unity 5.6.1[SOLVED]
« Reply #3 on: September 28, 2017, 03:38:08 PM »
Cool! Thanks for reporting this. I submitted a bug to Unity (Case 954335) and they were able to reproduce, so hopefully, they will fix it...

Rabagast

  • Hero Member
  • *****
  • Posts: 679
    • View Profile
    • Homepage
Re: Playmaker 1.8.5 doesn't work in Unity 5.6.1[SOLVED]
« Reply #4 on: September 30, 2017, 11:22:03 PM »
Hi!
No problem. :)
Check out our homepage. http://www.walsberg.no
Or my personal game blog for news about my games. http://retro-tetro.walsberg.no

Marc Saubion

  • Junior Playmaker
  • **
  • Posts: 57
    • View Profile
Re: Playmaker 1.8.5 doesn't work in Unity 5.6.1[SOLVED]
« Reply #5 on: February 22, 2018, 04:03:03 AM »
Cool! Thanks for reporting this. I submitted a bug to Unity (Case 954335) and they were able to reproduce, so hopefully, they will fix it...
Hi.

I don't think this was solved. I have to work on 5.5.6 for a client and had the same issue when installing Playmaker. The error message lead me here and even after restarting Unity and redownloading from the asset store, I still couldn't use Playmaker.

Hopefully, I had an older project with playmaker 1.8.3 on it and could install it.

Related error message: TypeLoadException: Could not load type 'UnityEngine.ImageConversion' from assembly 'PlayMakerEditor'.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3306
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Playmaker 1.8.5 doesn't work in Unity 5.6.1[SOLVED]
« Reply #6 on: February 27, 2018, 03:53:27 PM »
Weird. What version of Playmaker were you downloading?

It could be an asset store bug in that version of Unity.
If you have another version installed, you could try downloading in that version (e.g., Unity 5.4)

Unity has confirmed this is an issue with the current Asset Store. Unfortunately, it seems they don't have plans to fix it anytime soon given their response:

It was marked as "Wont fix" for now and will be touched once revamping the whole Asset Store in the next couple of years. We are sorry for inconvenience.