playMaker

Author Topic: Report Error When Importing Pathfinding Package [SOLVED]  (Read 78 times)

salmon

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Report Error When Importing Pathfinding Package [SOLVED]
« on: November 13, 2017, 06:14:12 AM »
Hi,

Sorry to bother.
When I tried to import the pathfinding package, unity reported this:

"Assets/PlayMaker PathFinding/Agent/GetAgentIsStopped.cs(71,31): error CS1061: Type `UnityEngine.AI.NavMeshAgent' does not contain a definition for `isStopped' and no extension method `isStopped' of type `UnityEngine.AI.NavMeshAgent' could be found. Are you missing an assembly reference?"

and

"Assets/PlayMaker PathFinding/Agent/SetAgentIsStopped.cs(58,11): error CS1061: Type `UnityEngine.AI.NavMeshAgent' does not contain a definition for `isStopped' and no extension method `isStopped' of type `UnityEngine.AI.NavMeshAgent' could be found. Are you missing an assembly reference?"

I pretty much have read all the post about this question. two of them are solved by updating their unity, because the versions they used is too old.(One is unity4.0, another is unity 5.5.03f)

And I'm using unity5.5.3f so I think the version I use is not that old.

And i try to import pathfinding package by github and ecosystem. None of them works.

So do i have to update my unity to the newest version so that can work?


Thanks
« Last Edit: November 15, 2017, 12:59:27 AM by Alex Chouls »

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 2254
    • View Profile
    • jinxtergames
Re: Report Error When Importing Pathfinding Package
« Reply #1 on: November 13, 2017, 05:05:18 PM »
Hi,
What playmaker version are you using?

salmon

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: Report Error When Importing Pathfinding Package
« Reply #2 on: November 13, 2017, 07:48:30 PM »
Hi,

I'm using 1.8.3 playmaker.

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 2254
    • View Profile
    • jinxtergames
Re: Report Error When Importing Pathfinding Package
« Reply #3 on: November 14, 2017, 12:39:20 AM »
Hi,
This seems to be solved on unity 5.6+ :

http://hutonggames.com/playmakerforum/index.php?topic=15777.0

Make a backup before you update

When you update you should also update playmaker :)
« Last Edit: November 15, 2017, 02:03:19 AM by djaydino »

salmon

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: Report Error When Importing Pathfinding Package
« Reply #4 on: November 14, 2017, 08:24:59 PM »


That works when upgrading to unity5.6.4


Thanks a lot!