playMaker

Author Topic: Changes in Playmaker getting lost when I hit play  (Read 2093 times)

SpencerPDX

  • Playmaker Newbie
  • *
  • Posts: 22
    • View Profile
Changes in Playmaker getting lost when I hit play
« on: May 23, 2015, 06:28:01 PM »
Hello!

I'm having a weird little problem here. I have a project that started out life as a Unity4 project, but which I've since brought into Unity5. After doing so I updated Playmaker and am now at 1.7.8.3. Playmaker has been apparently running fine, and I don't have any errors.

The problem: Not sure how frequently, but sometimes when I make changes in the Playmaker editor and then hit play, the changes are lost. You can see it happen in this screen capture:

http://screencast.com/t/MeWyBwUmxxry

There I'm going through and removing the word "Canvas" from the Set property names. I edit three of the names and hit play. As soon as the project runs the words Canvas reappear - the changes are lost.

I found mention of something like this here:

http://hutonggames.com/playmakerforum/index.php?topic=1974.msg8653#msg8653

But the solution there was to update Playmaker. From what I can tell, I'm currently up-to-date.

Perhaps coincidentally, this state machine was giving me trouble with some Set Properties I've since deleted. These were set to change the Text component of a 3D Text object. It was having so much trouble I tried the new UI > Text in world space instead. That seemed to work better, but then I realized as I continued to work that I was fixing things I could have sworn I had already fixed. :)

It started happening so consistently I caught it in that screen capture.

Another thing I wonder about: This state machine came into this new version as a prefab. Then I decided I'd rather work on a scene object instead of on the prefab, and broke the connection and deleted the prefab.

So maybe a few opportunities for mayhem to work its way in there. But it's been so solid overall that I don't feel like I'm seeing anything mentioned in the Unity5 troubleshooting guide.

Any help or suggestions would be greatly appreciated!


SpencerPDX

  • Playmaker Newbie
  • *
  • Posts: 22
    • View Profile
Re: Changes in Playmaker getting lost when I hit play
« Reply #1 on: May 23, 2015, 06:36:59 PM »
Just an update: There's an object called EventSystem that gets added to the scene when the UI>Text object is added. Don't know what it does, but I tried deactivating the EventSystem game object and again tried editing the word "Canvas" out of those same Playmaker actions. This time the changes stuck! So I turned EventSystem back on to see if it being active somehow prevents further changes... But it didn't. So it might have just been a coincidence. Or maybe EventSystem is somehow messing with Playmaker. Thought it worth a mention.

SpencerPDX

  • Playmaker Newbie
  • *
  • Posts: 22
    • View Profile
Re: Changes in Playmaker getting lost when I hit play
« Reply #2 on: May 25, 2015, 12:06:55 PM »
Another update: I continue to have Playmaker edits vanish as soon as I hit play. On the chance that I screwed up installing Playmaker, I followed the instructions here for "How to safely replace an old Playmaker installation with the latest version":

https://hutonggames.fogbugz.com/default.asp?W624

But that didn't fix the problem.

mdotstrange

  • Hero Member
  • *****
  • Posts: 551
    • View Profile
    • Can't code? Who cares! Make games anyway!
Re: Changes in Playmaker getting lost when I hit play
« Reply #3 on: May 25, 2015, 03:48:27 PM »
I had this same exact problem on a project recently- its really frustrating 0_0

I have since never had it again on other projects with the same version of Playmaker/Unity- my issues seemed to stem from some other assets I was using in that project- for me it was some old Substance Designer materials I had gotten from the asset store-

Also when  I had that issue it was happening only on prefabs- is that object that keeps reverting the values a prefab? Maybe try hitting apply on the prefab after making the changes or if you don't need it to be a prefab go to game objects "break prefab instance" to see if that helps-
Indie game dev and instructor at the Strange School. Learn Playmaker at the Strange School!

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14493
  • Official Playmaker Support
    • View Profile
Re: Changes in Playmaker getting lost when I hit play
« Reply #4 on: May 25, 2015, 11:20:22 PM »
Hi,

 The EventSystem Object is a Unity system, it MUST be left in your scene if you want your UI to work properly.

 Indeed, can you verfiy that you are correctly editing prefabs, make sure you always edit the prefab sitting in your project, NOT in your hierarchy. Else, hit apply as mdotstrange mentionned it.

I think this is the problem here. If you make another screencast, can you do full screen so we know what you are editing? thanks.

 Bye,

 Jean

SpencerPDX

  • Playmaker Newbie
  • *
  • Posts: 22
    • View Profile
Re: Changes in Playmaker getting lost when I hit play
« Reply #5 on: May 26, 2015, 12:32:46 AM »
Hi there,

Thanks very much for the replies.

The prefab thing could perhaps be an issue. It's not a prefab, but as I mentioned in my original post, it started out as one. But soon after I imported this old Unity4 project into Unity5, I kept trying to work on the instance. I couldn't remember why I even bothered making it a prefab back a year ago when I had last opened it. It was a pain click on the game object only to realize I was supposed to be editing the prefab instead, and I definitely wasn't going to change the settings to let me work on the instance while there was a prefab in existence. So I did a "break prefab instance" and deleted the prefab, then continued to work on the instance.

For this and other reasons I've mentioned in another post, I might just start over to make sure everything's clean after reinstalling Playmaker itself.

Thanks again!