playMaker

Author Topic: Errors updating array maker  (Read 2415 times)

RoiSinge

  • Playmaker Newbie
  • *
  • Posts: 14
    • View Profile
Errors updating array maker
« on: March 19, 2016, 09:50:13 AM »
Hi,

Updating array maker I got those errors :
Assets/PlayMaker ArrayMaker/__internal__/Editor/PlayMakerCollectionProxyInspector.cs(559,109): error CS1502: The best overloaded method match for `UnityEditor.EditorGUILayout.ObjectField(UnityEngine.Object, System.Type, params UnityEngine.GUILayoutOption[])' has some invalid arguments

Assets/PlayMaker ArrayMaker/__internal__/Editor/PlayMakerCollectionProxyInspector.cs(559,109): error CS1503: Argument `#1' cannot convert `Sprite' expression to type `UnityEngine.Object'

How can I fix this?

My Unity version is 5.3.3 and playmaker is 1.7.8.3

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15398
  • Official Playmaker Support
    • View Profile
Re: Errors updating array maker
« Reply #1 on: March 23, 2016, 09:32:56 AM »
Hi,

 I am looking into this. I will update when I have found how to fix this.

Bye,

 Jean

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15398
  • Official Playmaker Support
    • View Profile
Re: Errors updating array maker
« Reply #2 on: March 23, 2016, 11:59:34 PM »
Hi,

 Ok, the first thing is:

- you need to use PlayMaker 1.8 beta for Unity 5.3 and up.
- I am testing on 5.3.3 f1 and I don't have your first error, is it happening at runtime or just when editing?
- The second error is likely a corruption of data, so your hashtable expects Sprites it seems

Can you tell me which version of ArrayMaker you have? it's int he PlayMaker ArrayMaker/ folder under changeLog.md or versionInfo.json.

 Bye,

 Jean


RoiSinge

  • Playmaker Newbie
  • *
  • Posts: 14
    • View Profile
Re: Errors updating array maker
« Reply #3 on: March 24, 2016, 04:10:12 AM »
Hi Jean,

Well I can't update to 1.8 beta since it brings a bunch of errors as described here : http://hutonggames.com/playmakerforum/index.php?topic=12388.0
Besides, on 1.8 I get a lot of random "error loading action" at runtime which completely break the game.

I tried to switch back my project on unity 5.2.1f1, then updated array maker and I still get the same errors.

The errors are happening just after Unity finished compiling, then I can't launch the game anymore ("All compiler errors have to be fixed before you can enter playmode")

There is no changeLog.md or versionInfo.json files in the ArrayMaker folder, however there is a readme.txt file which tells me that I have version alpha 0.99 of ArrayMaker.

I don't know if it's related but I have changelog and versionInfo files in the DataMaker folder. I have version 1.0.3 of DataMaker.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15398
  • Official Playmaker Support
    • View Profile
Re: Errors updating array maker
« Reply #4 on: March 24, 2016, 11:12:59 PM »
Hi,

 0.99 is indeed very old. you need to get the latest from the Ecosystem ( 1.1.5 )

http://j.mp/1Oz63XC

As for not using 1.8, it's going to be either you stay on less then 5.3 and stuck with PlayMaker 1.7 or you move to 1.8.1 beta to be able to enjoy 5.3. Do you have access to the beta list to get the latest PlayMaker beta version?


Bye,

 Jean

RoiSinge

  • Playmaker Newbie
  • *
  • Posts: 14
    • View Profile
Re: Errors updating array maker
« Reply #5 on: March 25, 2016, 04:03:34 AM »
Update ArrayMaker from 0.99 to 1.1.5 is actually what I am trying to do, but it leads to the compiler errors mentioned in my first post. I checked the changelog after the update, the version is indeed 1.1.5 build 2.

Regarding playmaker 1.8, the most recent version available is 1.8.0 beta 43 (from the asset store). How can I get 1.8.1 ?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15398
  • Official Playmaker Support
    • View Profile
Re: Errors updating array maker
« Reply #6 on: March 25, 2016, 06:47:04 AM »
Hi,

 Likely, you  will have to go over the various fsm, because I doubt the 0.99 is fully compatible with the latest version of ArrayMaker, typically, because I added new types, and so the setup of your arrays and hashtable may be corrupted. you'll need to double check each one of them and make sure the type is the right one, it may have changed because of the incompatibility between the arrayMaker versions.

 To access the latest beta, you need to contact us ( pm me) and give us a  valid gmail address, then I'll forward that to Alex so that you get access to it.

Bye,

 Jean

RoiSinge

  • Playmaker Newbie
  • *
  • Posts: 14
    • View Profile
Re: Errors updating array maker
« Reply #7 on: March 26, 2016, 04:56:05 AM »
Ok thanks, I'll try to check each ArrayMaker related action, but it's going to take a while since my project is pretty large.

And I just PM you to request an access to 1.8.1 beta.