playMaker

Author Topic: Getting MissingReferenceException [SOLVED]  (Read 1049 times)

cobra01

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
Getting MissingReferenceException [SOLVED]
« on: March 29, 2012, 12:44:21 PM »
The object of type "PlaymakerFSM" has been destroyed but you are still trying to access it.

I have 2 levels i load in the very same way, in one event i can toggle between the 2 levels with no errors or issues, on the other i can load the main level but when i click the button that loads the next scene it transitions but then sits there with this error msg.

Ive tried changing how to load the scene a couple of time (many couple of times) and the issue arises everytime i add a PlaymakerFSM to the scene, without it the lvl loads fine with no issues so each time i remove the FSM the level loads, add an FSM and its a bust.

It weird that the other scene does not have this issue at all. Ive read upon all the other MissingReferenceExceptions and nothing really helps, i am using version 1.3.2.

« Last Edit: March 30, 2012, 03:06:27 PM by Alex Chouls »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3581
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Getting MissingReferenceException
« Reply #1 on: March 29, 2012, 01:30:47 PM »
This issue is fixed in 1.3.3. I'll send you an invite to the beta so you can verify the fix. Please PM me the address you'd like to use to join the PlayMaker Beta Testing group. Thanks!