playMaker

Author Topic: Error after updating Photon to 1.75[SOLVED]  (Read 5000 times)

ZenDesign

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Error after updating Photon to 1.75[SOLVED]
« on: September 02, 2016, 06:45:07 PM »
Hi,
I'm using Unity 5.4 and Playmaker 1.8.2. I'm getting this error message:

Assets/PlayMaker PUN/Scripts/PlayMakerPhotonGameObjectProxy.cs(83,29): error CS0019: Operator `!=' cannot be applied to operands of type `PhotonMessageInfo' and `null'

Thanks
« Last Edit: September 13, 2016, 02:05:50 AM by jeanfabre »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15494
  • Official Playmaker Support
    • View Profile
Re: Error after updating Photon to 1.75
« Reply #1 on: September 05, 2016, 04:35:50 AM »
Hi,

 yes, an update is coming this week for PlayMaker to comply with the latest iteration of PUN. Thanks for your patience :)

 Bye,

 Jean

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15494
  • Official Playmaker Support
    • View Profile
Re: Error after updating Photon to 1.75
« Reply #2 on: September 07, 2016, 07:08:32 AM »
Hi,

 Update available now :)

Bye,

 Jean

ZenDesign

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: Error after updating Photon to 1.75
« Reply #3 on: September 08, 2016, 07:08:06 PM »
Hi,
I've updated Playmaker to 1.8.3 and I'm still getting the same error.  I created a new project and installed Playmaker, Playmaker PUN and Photon and received the same error message. 

Thanks

devmodeon

  • Playmaker Newbie
  • *
  • Posts: 5
    • View Profile
Re: Error after updating Photon to 1.75
« Reply #4 on: September 08, 2016, 08:10:20 PM »
I had to download the files from Github and copy/paste them into the matching assets folders. Also it worked perfectly after I unchecked the Pick Best Server option.

oops here is the link: https://github.com/jeanfabre/PlayMaker--ExitGames--PhotonUnityNetworking_U5
« Last Edit: September 08, 2016, 08:12:20 PM by devmodeon »

Jin

  • Playmaker Newbie
  • *
  • Posts: 14
    • View Profile
Re: Error after updating Photon to 1.75
« Reply #5 on: September 10, 2016, 02:13:46 AM »
Hi All!
I am attempting to add PUN to my game using "Easy PUN Setup Playmaker".
I cannot test/compile due to this error:

Assets/PlayMaker PUN/Scripts/PlayMakerPhotonGameObjectProxy.cs(83,29): error CS0019: Operator `!=' cannot be applied to operands of type `PhotonMessageInfo' and `null'

I am using Unity 5.4.of3 Personal (64bit) and Playmaker 1.8.2
I have attempted reimporting. I also purged all related files and
reinstalled. As well I tried the github suggestion in this thread.
No success so far. I feel stumped. Any other ideas?

Thanks, Jinnn
« Last Edit: September 10, 2016, 02:27:51 AM by Jin »

devmodeon

  • Playmaker Newbie
  • *
  • Posts: 5
    • View Profile
Re: Error after updating Photon to 1.75
« Reply #6 on: September 10, 2016, 02:30:30 AM »
 Scratch that I just loaded 5.4.0f3 65bit* imported playmaker 1.8.3, imported photon 1.75, copied the files from the Git(PlayMaker--ExitGames--PhotonUnityNetworking_U5\Assets) and it worked fine. I only copied 5 folders PlayMaker Custom Actions, Custom Samples, PUN, Utils and Plugins. Pasted them directly into my new project and loaded up the worker sample straight away with no errors.
« Last Edit: September 10, 2016, 02:50:20 AM by devmodeon »

Jin

  • Playmaker Newbie
  • *
  • Posts: 14
    • View Profile
Re: Error after updating Photon to 1.75
« Reply #7 on: September 11, 2016, 04:15:24 PM »
I am glad that is working for you. I assume you are importing PlayMakerPUN.unitypackage as well?

I just followed those instructions with the addition of PlayMakerPUN.unitypackage
and still have the error whether I open DemoWorker-Scene  or DemoWorkerGame-Scene

It's a fresh project with fresh install of playmaker 1.8.3 and photon v.1.75 with those Git folders copied and pasted over as described.

I only see one error:

Assets/PlayMaker PUN/Scripts/PlayMakerPhotonGameObjectProxy.cs(83,29): error CS0019: Operator `!=' cannot be applied to operands of type `PhotonMessageInfo' and `null'

Anyone who has had experience getting rid of the error, I would appreciate advice.

Thanks, Jin

devmodeon

  • Playmaker Newbie
  • *
  • Posts: 5
    • View Profile
Re: Error after updating Photon to 1.75
« Reply #8 on: September 11, 2016, 11:02:49 PM »
Okay I have replicated the error and gotten rid of it with the steps I listed before. I did not import the PUN package. I will list the steps in the order I did them starting a new project from scratch in unity 5.4.

1. Import and Install Playmaker 1.8.3

2. Import Photon 1.75

3. Go to this link https://github.com/jeanfabre/PlayMaker--ExitGames--PhotonUnityNetworking_U5 Click Clone and Open in Desktop. Choose a folder I put it in a new folder on my desktop called playmakerJIN.

4. I opened up the newly cloned folders and selected 5 folders within the Assets folder. PlayMaker Custom Actions, PlayMaker Custom Samples, PlayMaker PUN, PlayMaker Utils, Plugins.

5. I copy and pasted them into my new project called playmakerJIN Assets folder. Overwriting the current files.

6. I then opened up the DemoWorker scene within the included Custom Samples folder from the GIT clone.

7. setup my photon cloud.

8. clicked on Menu in the Hierarchy, clicked on connect, unchecked Connect to Best Server.

9. Hit Play all is dandy, ignore any errors you may get at first from the copy/paste action from meta files and such.

That is my actual experience for fixing the problem that I also had. Hope it helps. I'll make a video if you need also.


Jin

  • Playmaker Newbie
  • *
  • Posts: 14
    • View Profile
Re: Error after updating Photon to 1.75
« Reply #9 on: September 12, 2016, 12:47:18 AM »
Thanks for your detailed answer.
I followed your instructions and did load DemoWorker
without the error from this thread showing up.

When I pressed play though, it didn't work and I saw
many errors show up referring to "missing actions"

I started a new thread about that here:
http://hutonggames.com/playmakerforum/index.php?topic=13547.msg62984#msg62984

Thanks again for trying to help.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15494
  • Official Playmaker Support
    • View Profile
Re: Error after updating Photon to 1.75
« Reply #10 on: September 12, 2016, 08:00:22 AM »
Hi,

 Make sure you download pun from the Ecosystem again. I simply forgot to push the Unity 5 version last time.. d'oh...

 Bye,

 Jean

Jin

  • Playmaker Newbie
  • *
  • Posts: 14
    • View Profile
Re: Error after updating Photon to 1.75
« Reply #11 on: September 13, 2016, 01:18:21 AM »
Thanks! that worked to get rid of that error.

I was unable to access ecosystem all weekend,
but I appreciate your reply and I am happy
that ecosystem is working again too.