playMaker

Author Topic: Error Message after 1.8.3 upgrade  (Read 1363 times)

hwilliams

  • Playmaker Newbie
  • *
  • Posts: 9
    • View Profile
Error Message after 1.8.3 upgrade
« on: January 23, 2017, 04:37:00 AM »
After upgrading to 1.8.3 (which is a big improvement over my previous version, thank you!) I get this message, and was wondering if it would be fixed in 1.8.4:

get_realtimeSinceStartup is not allowed to be called during serialization, call it from Awake or Start instead. See "Script Serialization" page in the Unity Manual for further details.

I'm also getting some warnings about missing variables, but in many of the cases the messages are inaccurate to the variable or state, or the warning is wrong and the variable isn't missing. Is there a way to turn these warnings off?

Thanks!

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Re: Error Message after 1.8.3 upgrade
« Reply #1 on: January 23, 2017, 11:53:48 PM »
Hi,

- What version of Unity are you using?

- what asset is the error coming from? if you click ont he error in the log it should highlight an asset.

- for the warnings, if you hit play does it work?

Bye,

 Jean



hwilliams

  • Playmaker Newbie
  • *
  • Posts: 9
    • View Profile
Re: Error Message after 1.8.3 upgrade
« Reply #2 on: January 26, 2017, 09:21:51 PM »
Hi, Thanks for getting back to me!

I'm using Unity 5.5.0.

This is the error:
get_realtimeSinceStartup is not allowed to be called during serialization, call it from Awake or Start instead. Called from MonoBehaviour 'PlayMakerFSM' on game object '+ Menu Canvas'.
See "Script Serialization" page in the Unity Manual for further details.
UnityEngine.Time:get_realtimeSinceStartup()
HutongGames.PlayMaker.FsmTime:get_RealtimeSinceStartup() (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Classes/FsmTime.cs:56)
etc...

The warnings don't alter anything, I just wish that if they were going to tell me I have a missing variable that they were accurate to what was actually missing so I could fix/remove the action.

artician

  • 1.2 Beta
  • Sr. Member
  • *
  • Posts: 298
    • View Profile
Re: Error Message after 1.8.3 upgrade
« Reply #3 on: March 14, 2017, 07:31:12 AM »
Did anything ever come of this?  I regularly receive the error now as well, and it's getting worse.  It just decides to pop up on all sorts of otherwise-working FSM's now.  Posting now because it's currently holding me up (whereas before I could ignore it, or it would go away if I restarted Unity).

Running Unity 5.4.2 and PlayMaker 1.8.3

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Re: Error Message after 1.8.3 upgrade
« Reply #4 on: March 15, 2017, 12:17:53 AM »
Hi,

 If Recall properly, it's because you need to move actions using time from the start state to another state. Can you confirm you have such actions on that gameobject?

 Bye,

 Jean

artician

  • 1.2 Beta
  • Sr. Member
  • *
  • Posts: 298
    • View Profile
Re: Error Message after 1.8.3 upgrade
« Reply #5 on: March 16, 2017, 08:50:09 AM »
I started the project up to check, and it just stopped.  All on it's own.  :( 

There were no time-related actions in that FSM.  If it happens again I'll post more info.