playMaker

Author Topic: Sending emails with Playmaker?  (Read 1926 times)

ilovelessons

  • Junior Playmaker
  • **
  • Posts: 70
    • View Profile
Sending emails with Playmaker?
« on: May 26, 2017, 03:49:46 PM »
Hi,

Does anyway know how to send text to an email address using playmaker? I only see one action in the Action Browser called GUI Layout Email Field.  Is there any I can get from Ecosystem?

Thanks


Ateam

  • Full Member
  • ***
  • Posts: 115
    • View Profile
Re: Sending emails with Playmaker?
« Reply #1 on: May 26, 2017, 06:09:25 PM »
You can use https://www.assetstore.unity3d.com/en/#!/content/71483
and with playmaker use the Call Method

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15467
  • Official Playmaker Support
    • View Profile
Re: Sending emails with Playmaker?
« Reply #2 on: September 15, 2017, 04:22:54 AM »
Hi,

 if you target mobile, don't forget to use the linker wizard for your callmethod to properly register what class it's calling else it won't be seen by Unity during compilation and feature won't work.

http://hutonggames.com/playmakerforum/index.php?topic=11126.0
 Bye,

 Jean

fromfame

  • Junior Playmaker
  • **
  • Posts: 74
  • Sloppy PM Veteran
    • View Profile
Re: Sending emails with Playmaker?
« Reply #3 on: March 03, 2019, 01:04:00 PM »
If you're having a hard time, here're important missed points:
  • After downloading the email asset, import it, then in Unity go to Edit>Project Settings>Player>Other Settings and change .Net Subset to .Net 2.0
  • Don't worry if you have no idea what SMTP means, open the example
    scene, hit play, and fill this is forum:
         SMTP Client:
         smtp.gmail.com, smtp.yahoo.com, etc. That's all.
         SMTP Port:
         587, if console says port is wrong, 465. These are the only two ports for sending               emails.
         Username:
         Email you wanna send from
         User pass:
         Your password for the email you're sending from. (it's to verify)
  • Now try sending, it'll say "wrong username/pass". Don't worry you're not delusional, what's actually happening is your SMTP client blocked you in unity.
  • For gmail, Sign In>click your icon>[Google Account]>Security>Less Secure Apps>Allow.
  • If you can't see 'Less Secure App Access' you're on G Suite and need to enable it on admin first: admin.google.com>Security>Basic Settings>Less Secure Apps>Allow. Then allow it on your email
The rest is self explanatory, I'm currently trying to find a way to get the email asset's public variables to accept TextMeshPro Inputfields but no idea how, so got in touch with the developer.
« Last Edit: March 03, 2019, 01:07:50 PM by fromfame »