playMaker

Author Topic: Ecosystem 0.5.1 bug (SOLVED)  (Read 3025 times)

tankun

  • Playmaker Newbie
  • *
  • Posts: 26
Ecosystem 0.5.1 bug (SOLVED)
« on: July 27, 2017, 06:16:17 AM »
Hi,

Just installed the new ecosystem Browser.

Got this fatal error;

Assets/net.fabrejean/Editor/PlayMaker/Ecosystem/EcosystemBrowser.cs(2361,16): error CS0029: Cannot implicitly convert type `UnityEngine.WWW' to `HutongGames.PlayMaker.Ecosystem.Utils.WWW'

Using Unity 2017.1.0f3

Thanks
« Last Edit: August 03, 2017, 12:03:37 PM by tankun »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15496
  • Official Playmaker Support
Re: Ecosystem 0.5.1 bug
« Reply #1 on: July 27, 2017, 10:24:37 AM »
Hi,

 yes, turn off beta features, I haven't yet ported beta features for this 2017.1 version.

 bye,

 Jean

Pandur

  • Full Member
  • ***
  • Posts: 122
Re: Ecosystem 0.5.1 bug
« Reply #2 on: July 28, 2017, 07:14:59 AM »
hi  i have a other Problem i will download the function Get Signed Angle to Target but i became this error
Code: [Select]
NullReferenceException: Object reference not set to an instance of an object
System.IO.File.WriteAllBytes (System.String path, System.Byte[] bytes) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.IO/File.cs:595)
Net.FabreJean.PlayMaker.Ecosystem.EcosystemBrowser+<ProceedWithImport>c__Iterator0.MoveNext () (at Assets/net.fabrejean/Editor/PlayMaker/Ecosystem/EcosystemBrowser.cs:2893)
Net.FabreJean.UnityEditor.EditorCoroutine.update () (at Assets/net.fabrejean/Editor/Plugins/EditorCoroutine.cs:53)
UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at C:/buildslave/unity/build/Editor/Mono/EditorApplication.cs:109)

i have it not testet with other functions from ecosystem.

tankun

  • Playmaker Newbie
  • *
  • Posts: 26
Re: Ecosystem 0.5.1 bug
« Reply #3 on: July 29, 2017, 04:11:04 AM »
Thanks Jean,

It worked yet with a trick. Since beacuse of the error, you can't run even the Ecosystem Browser; install 0.5.0 previous version. Disable Ecosystem's Beta Features. Delete net.fabrejean folder, then install Ecosystem 0.5.1.

Voila, the new version will have the Beta Features Disabled.



tankun

  • Playmaker Newbie
  • *
  • Posts: 26
Re: Ecosystem 0.5.1 bug
« Reply #4 on: July 29, 2017, 02:35:57 PM »
Hi Jean,

This time Ecosystem won't download or install the actions giving this error:

NullReferenceException: Object reference not set to an instance of an object
System.IO.File.WriteAllBytes (System.String path, System.Byte[] bytes) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.IO/File.cs:595)
Net.FabreJean.PlayMaker.Ecosystem.EcosystemBrowser+<ProceedWithImport>c__Iterator0.MoveNext () (at Assets/net.fabrejean/Editor/PlayMaker/Ecosystem/EcosystemBrowser.cs:2893)
Net.FabreJean.UnityEditor.EditorCoroutine.update () (at Assets/net.fabrejean/Editor/Plugins/EditorCoroutine.cs:53)
UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at C:/buildslave/unity/build/Editor/Mono/EditorApplication.cs:109)

Searching works though. I've already disabled the beta fatures.

Thanks.

Edit: Interestingly the downloaded scripts are where they should be but they are 0 bytes.
« Last Edit: July 29, 2017, 02:39:40 PM by tankun »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15496
  • Official Playmaker Support
Re: Ecosystem 0.5.1 bug
« Reply #5 on: July 31, 2017, 02:55:03 AM »
Hi,

 what actions specifically is it failing?

 what if you try to update the action that failed to load properly?

 Bye,

 Jean

tankun

  • Playmaker Newbie
  • *
  • Posts: 26
Re: Ecosystem 0.5.1 bug (SOLVED)
« Reply #6 on: August 03, 2017, 12:03:18 PM »
Oh all of the actions were failing to import but now with the new update (0.5.2) the problem is gone. Thank you Jean.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15496
  • Official Playmaker Support
Re: Ecosystem 0.5.1 bug (SOLVED)
« Reply #7 on: August 04, 2017, 03:08:32 AM »
Hi,

 Good, that was a tricky call cause I could not replicate it, thanks to Alex who saved the day one more time with finding out what was wrong!

 Bye,

 Jean

Romainhd

  • Playmaker Newbie
  • *
  • Posts: 2
Re: Ecosystem 0.5.1 bug (SOLVED)
« Reply #8 on: November 24, 2020, 11:00:28 AM »
Hi, I got that same error message today.Thanks