playMaker

Author Topic: state stop on first send event action  (Read 1271 times)

Marc Saubion

  • Beta Group
  • Junior Playmaker
  • *
  • Posts: 77
    • View Profile
state stop on first send event action
« on: April 07, 2018, 01:26:22 PM »
Hi.

I have some states using one or more send event before some other actions. On some occasions, playmaker stop on them and don't go further. I don't know yet why it's doing that: I cloned a gameobject having that issue and one worked file while the other stayed stuck on the send event action. See the screenshot below with one event displayed like a "every frame" even though it is not.

One way to dealing with it is to set the "send event" isolated on their own state. It's messy since you end up with a string of states but it works.

I hope this can be dealt with soon though because I wrote a lot of FSMs susceptible to failure because of this bug.

Thanks


tcmeric

  • Beta Group
  • Hero Member
  • *
  • Posts: 745
    • View Profile
Re: state stop on first send event action
« Reply #1 on: April 07, 2018, 05:14:23 PM »
An error on that FSM or another FSM can prevent a state from completing. Likely there is an error somewhere that is causing this stall in the FSM.

Marc Saubion

  • Beta Group
  • Junior Playmaker
  • *
  • Posts: 77
    • View Profile
Re: state stop on first send event action
« Reply #2 on: April 07, 2018, 06:35:27 PM »
Good to know but that's not it.  :-\

I had one error on an unrelated prefab. I corrected it and still have the same issue.

GonerGames

  • Junior Playmaker
  • **
  • Posts: 53
    • View Profile
Re: state stop on first send event action
« Reply #3 on: April 07, 2018, 06:59:07 PM »
A quick guess is that on your GO goupille it is not on the correct state to accept the UNLOCK send event.
ie. If it is on the first state and that state does not have the UNLOCK event on it then this send event won't fire.
Second guess is that your FSM Name does not match correctly.


Marc Saubion

  • Beta Group
  • Junior Playmaker
  • *
  • Posts: 77
    • View Profile
Re: state stop on first send event action
« Reply #4 on: April 09, 2018, 10:46:27 AM »
I'm afraid not. I had some issues on a FSM not receiving some events and solved it just by isolating the send event action on a state. The issue seems to be on the sender and not the receiver.

Note these last days were the first time I encountered this issue while working with templates more than usual. It didn't happen before.

Marc Saubion

  • Beta Group
  • Junior Playmaker
  • *
  • Posts: 77
    • View Profile
Re: state stop on first send event action
« Reply #5 on: April 18, 2018, 03:22:20 PM »
Good news everyone, I met that bug again and found the issue.  8)

As you can see from the screenshots below, the event was well sent and executed, so the issue is more subtle than that.

My mistake was using a "set fsm Texture" while my target was expecting an object (sprite). Once I set things up correctly, my FSM worked fine again.

@PlaymakerTeam, while the cause seems benign, it caused seemingly unrelated troubles like forcing sub FSMs to finish and missing actions. An error freezing the game and pointing the user to the badly configured set FSM action could save you from mysterious bug reports like mine. These might be specific to the Template workflow.

Thanks again for your help.  :D