playMaker

Author Topic: 1.9.0 Issue[SOLVED]  (Read 4158 times)

Harbingers

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
1.9.0 Issue[SOLVED]
« on: May 26, 2018, 11:23:10 PM »
Hi

How can resolve that issue?:

Assets/PlayMaker Utils/PlayMakerUtils_FsmVar.cs(372,33): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'

Assets/PlayMaker Utils/PlayMakerUtils_FsmVar.cs(450,32): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'

Assets/PlayMaker Utils/PlayMakerUtils_FsmVar.cs(452,21): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'

Playmaker ver. 1.9.0, Unity ver. 2018.1.1f1

P.S. Sorry for my bad english.





« Last Edit: June 02, 2018, 05:28:38 AM by djaydino »

DaiDesign

  • Playmaker Newbie
  • *
  • Posts: 16
    • View Profile
Re: 1.9.0 Issue
« Reply #1 on: May 27, 2018, 01:37:10 PM »
Hi

Not sure if this is the correct way but I commented out those lines and it was fine after.

Lines: 369-376
Quote
            #if UNITY_WEBGL
            // proceduralMaterial not supported
            #else
//dai            if (valueType.Equals(typeof(ProceduralMaterial))) // we are ok
//dai            {
//dai               ok = true;
//dai            }
            #endif

and

Lines: 447-453
Quote
      #if UNITY_WEBGL
      // proceduralMaterial not supported
      #else
//dai      }else if(valueType == typeof(ProceduralMaterial) ){
//dai         FsmMaterial _target= fromFsm.Variables.GetFsmMaterial(fsmVar.variableName);
//dai         _target.Value = (ProceduralMaterial)value;
      #endif

Just a quick fix

stvbabb

  • Junior Playmaker
  • **
  • Posts: 66
    • View Profile
Re: 1.9.0 Issue
« Reply #2 on: May 28, 2018, 10:09:37 AM »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3634
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: 1.9.0 Issue
« Reply #3 on: May 29, 2018, 05:16:28 AM »
PlayMakerUtils are included in some packages on the ecosystem (it's not part of the base install). Try downloading the latest version of any packages you imported from the ecosystem. If that doesn't work, Jean will need to update those packages...

Importing the new Substance tools might also work, but I haven't tried them yet.

Hayato

  • Playmaker Newbie
  • *
  • Posts: 15
    • View Profile
Re: 1.9.0 Issue
« Reply #4 on: May 31, 2018, 10:01:40 AM »
I got the same problem when getting last version of DataMaker , too .
But it can fix by import "PlayMakerUtils" package in ecosystem or GitHub link.




Playmaker ver. 1.9.0, Ecosystem 0.6.1 Unity ver. 2018.1.0f2
« Last Edit: January 28, 2019, 05:49:29 AM by jeanfabre »

Harbingers

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
Re: 1.9.0 Issue
« Reply #5 on: June 02, 2018, 05:14:50 AM »
I got the same problem when getting last version of DataMaker , too .
But it can fix by import "PlayMakerUtils" package in ecosystem or GitHub page.
https://github.com/jeanfabre/PlayMakerCustomActions_U4/blob/master/PlayMaker/Ecosystem/Custom%20Packages/Utils/PlayMakerUtils.unitypackage



Playmaker ver. 1.9.0, Ecosystem 0.6.1 Unity ver. 2018.1.0f2

BIG THANKS  :)

P.S. issue resolved
« Last Edit: June 02, 2018, 05:23:07 AM by Harbingers »

wheretheidivides

  • Sr. Member
  • ****
  • Posts: 496
    • View Profile
Re: 1.9.0 Issue[SOLVED]
« Reply #6 on: June 18, 2018, 12:36:48 PM »
I just don't understand gethub.  Is there a way just to post the code soit can be downloaded?  With the errors in unity, playmaker does not work so one can not use the ecosystem.

szomaza

  • Sr. Member
  • ****
  • Posts: 253
    • View Profile
Re: 1.9.0 Issue[SOLVED]
« Reply #7 on: June 19, 2018, 08:17:14 AM »
I just don't understand gethub.  Is there a way just to post the code soit can be downloaded?  With the errors in unity, playmaker does not work so one can not use the ecosystem.

I had the same problem.
Just go to the Github link, press download to get the PlayMakerUtils.unitypackage then double click to import it into your running Unity, and the error goes away.

cmvrgr

  • Junior Playmaker
  • **
  • Posts: 64
    • View Profile
Re: 1.9.0 Issue[SOLVED]
« Reply #8 on: January 19, 2019, 01:08:26 PM »
The link in GH is not working.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14701
  • Official Playmaker Support
    • View Profile
Re: 1.9.0 Issue[SOLVED]
« Reply #9 on: January 20, 2019, 11:20:50 PM »
Hi,

 where did you get the Github link?

Bye,

 Jean

szomaza

  • Sr. Member
  • ****
  • Posts: 253
    • View Profile

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14701
  • Official Playmaker Support
    • View Profile
Re: 1.9.0 Issue[SOLVED]
« Reply #11 on: January 28, 2019, 05:50:00 AM »
Hi,

 I see.
 
the link is this one now

Bye,

 Jean