playMaker

Author Topic: Debug Log doesn't start logging until PlayMaker editor window opened  (Read 551 times)

nickfourtimes

  • Playmaker Newbie
  • *
  • Posts: 27
    • View Profile
I'm just logging some info so I can see what's going on within a build. One state has Build String and a Debug Log actions (the log is written to the Unity Log as well); then there's a Next Frame Event which jumps back into the same state. I expect this to just do the logging once per frame.

When I run the game in the editor, I don't see any logging. However, if I choose any FSM component, and hit the Edit button so that the PlayMaker editor window is opened, then the logging begins immediately, and continues even if I close the PM window.

The logging does not work at all in a build on device (iOS).

Is there a reason the logging doesn't happen until a PlayMaker window is opened in editor? Is there a way to get the logging to work in a build as well, so I can read it out from the Xcode console?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14692
  • Official Playmaker Support
    • View Profile
Re: Debug Log doesn't start logging until PlayMaker editor window opened
« Reply #1 on: August 24, 2018, 12:44:20 AM »
Hi,

 there is a "forward to Unity Log" preference, have you tried this?



 Bye,

 Jean

nickfourtimes

  • Playmaker Newbie
  • *
  • Posts: 27
    • View Profile
Re: Debug Log doesn't start logging until PlayMaker editor window opened
« Reply #2 on: August 24, 2018, 07:52:56 AM »
Hm... well I could have sworn that I did do that, but in fact I hadn't.

However, even when I check that box (as well as checking "Send To Unity Log" in the Debug Log action – is there a major difference?), the logging still doesn't show up until I click "Edit" to edit an FSM. Naturally this doesn't work in a build either.

I've been able to reproduce this in an empty project – Unity 2017.3.1f1 and PlayMaker 1.9.0.
« Last Edit: August 24, 2018, 08:05:02 AM by nickfourtimes »