playMaker

Author Topic: Trying to trigger particles  (Read 419 times)

Tangled Rays

  • Playmaker Newbie
  • *
  • Posts: 32
    • View Profile
Trying to trigger particles
« on: February 19, 2019, 03:09:00 PM »
Hi all, I'm trying to trigger particles I have as children of my player character, I have tried different combinations of trigger event and get object, get child, find game object, activate game object, but nothing seems to work. The particles trigger when the scene opens, but not when they are supposed to. Any help would be appreciated, thank you! :)

Gav (HeyBud)

  • Full Member
  • ***
  • Posts: 117
    • View Profile
    • Tumblr
Re: Trying to trigger particles
« Reply #1 on: February 19, 2019, 03:18:04 PM »
You can try starting with the particles disabled, then Activate Game Object when you want them to run. They need to be off before using activate game object or it will just keep them active.

Another way is to make a prefab of the particle system and use Create Object to spawn them at the position or game object you need.
« Last Edit: February 19, 2019, 03:20:57 PM by Gav (HeyBud) »

Tangled Rays

  • Playmaker Newbie
  • *
  • Posts: 32
    • View Profile
Re: Trying to trigger particles
« Reply #2 on: February 19, 2019, 04:17:30 PM »
Okay, cool, thank you, I'll give those a go  ;)

Tangled Rays

  • Playmaker Newbie
  • *
  • Posts: 32
    • View Profile
Re: Trying to trigger particles
« Reply #3 on: February 19, 2019, 05:27:14 PM »
Right I think the problem is that I'm using the Corgi engine and the particles are only appearing at the origin spawn point of my character at the start of the level, despite having the player character set as the position of object creation. I will try creating a global variable that stores the players position, and use that as the spawn point.

miguelfanclub

  • Full Member
  • ***
  • Posts: 152
    • View Profile
Re: Trying to trigger particles
« Reply #4 on: February 25, 2019, 05:56:41 AM »
There are Particle Play and Particle Stop actions.