playMaker

Author Topic: Asset Store bug and how to download the correct PlayMaker Package  (Read 776 times)

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14126
  • Official Playmaker Support
    • View Profile
Hi Everyone,

 Unity Asset Store has a bug where if you have several versions of Unity installed on your computer, the Asset store is not handling the cache properly and will try to install the wrong version ( PlayMaker is published with multiple versions for optimal compatibility with Unity). There is nothing we can do from our side: All assets are subjects to this issue when distributed via the Asset Store. On top of that, it is not straight forward to solve this, so here's the step by step instructions:

-----------------------------------------
1: Switch to the old asset store



2: Go to "Download Manager"



2: Locate PlayMaker asset and download it



4: Import it


-----------------------------------------

You should only do this when PlayMaker install procedure explicitly tells you to do that ( if you have the latest version). If you have older versions of PlayMaker, you will get various errors instead of a nice warning, and you'll need to follow the same procedure. Make sure you always search this forum for your errors in your console, there is a very high chance that it is already covered in a thread.

If you have questions, please open a new thread and ping me via pm if you don't get a reply within 2-3 days.

Hopefully, the Unity Asset Store interface will improve to let us redownload the correct package with a more direct and intuitive interface, so feel free to contact the asset store and kindly request a fix/improvement on this issue. The more feedback they get the better for everyone.

Bye,

 Jean