playMaker

Author Topic: After build some actions are flagged as "missing" (but not in the editor)  (Read 433 times)

stack_overflower

  • Playmaker Newbie
  • *
  • Posts: 5
    • View Profile
Hello there! Hope you all are doing well.
Here is my problem: recently, just after a build was completed, I started getting some errors telling me that some actions were "missing" from some states. Of course the actions were there, because in the editor everything was completely fine. Unfortunately I cannot share my project because of the contract we have. Can you guys help me?

Thanks a lot.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3632
  • Official Playmaker Support
    • View Profile
    • LinkedIn
What versions of Unity, Playmaker and which build target?

stack_overflower

  • Playmaker Newbie
  • *
  • Posts: 5
    • View Profile
What versions of Unity, Playmaker and which build target?
I am using PlayMaker 1.8.9.f1, Unity 2017.2.5f1 and build target is Windows.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3632
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Did you recently add any new scripts to the project?

I would also try updating to the latest version of PlayMaker (1.9.0.p15).



stack_overflower

  • Playmaker Newbie
  • *
  • Posts: 5
    • View Profile
Did you recently add any new scripts to the project?

I would also try updating to the latest version of PlayMaker (1.9.0.p15).

Yes I constantly add playmaker actions to the project. It's a beat 'em up game and we rely on PlayMaker to create combos for the characters.

I could try to upgrade, do you have any advice for the process? (is there anything that I can manually do before the update to avoid errors after it?)

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 4522
    • View Profile
    • jinxtergames
Hi.
For updating from 1.8.9 to 1.9, there should not be issues.

BUT always make a backup of your project before updating!

if you click on the missing action warnings, they should redirect you to the state with the missing action.

It should now have a 'missing action' action and it should have a name of the missing action.

What are the names stated there ?
FOR HIRE:Playmaker/C#

Playmaker Samples <-------------> Easy Exporter <---------------------> TPA Actions

stack_overflower

  • Playmaker Newbie
  • *
  • Posts: 5
    • View Profile
Hi.
For updating from 1.8.9 to 1.9, there should not be issues.

BUT always make a backup of your project before updating!

if you click on the missing action warnings, they should redirect you to the state with the missing action.

It should now have a 'missing action' action and it should have a name of the missing action.

What are the names stated there ?

Hello! We always use versioning so there is no problem for backups!

For what concernes the actions: it only happens in the build, not in the editor - as I said.
So if I play the game from the editor everything is fine, but from the build I get those errors (from the screenshot). I double checked and all those actions exist in the project and work well. That is the strangest thing ever. I could try to delete them, re-create them and re-use them in the states they were before.

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 4522
    • View Profile
    • jinxtergames
Hi.
sorry for my misunderstanding.

You could try using the linker wizard, but not sure if this will help in this case.
FOR HIRE:Playmaker/C#

Playmaker Samples <-------------> Easy Exporter <---------------------> TPA Actions