playMaker

Author Topic: BroadcastEvent.cs on START doesn't fire the FINISH transition [FIXED]  (Read 2031 times)

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14501
  • Official Playmaker Support
    • View Profile
Hi,


 If I plug a broadcastEvent.cs on a state following a START event ( on the first frame of the game), that state never reach the FINISH transition. I know this is not a good thing to do, but the fact that its hanging is wrong I think. If I toggle a breakpoint all is well, but if I don't, then it just hang there, the state is green, the action is not dimmed and it doesn't fire the FINISH transition attached to that state.


I am not using this set up, I ended up there by mistake, but if the broadcast action doesn't work, it should at least properly send the finish() call I think. Else I think it needs a bigger disclaimer on the doc for this case.

 Jean
« Last Edit: October 06, 2011, 01:11:55 PM by alexchouls »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3632
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: BroadcastEvent.cs on START doesn't fire the FINISH transition
« Reply #1 on: August 09, 2011, 08:20:24 PM »
I just tried this with SendEvent in 1.2 (which replaces BroadcastEvent) and it seems to be fixed...

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3632
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: BroadcastEvent.cs on START doesn't fire the FINISH transition [FIXED]
« Reply #2 on: October 06, 2011, 01:12:33 PM »
Thanks!