playMaker

Author Topic: Can't Download 1.2 [SOLVED]  (Read 4067 times)

FractalCore

  • 1.2 Beta
  • Junior Playmaker
  • *
  • Posts: 97
    • View Profile
Can't Download 1.2 [SOLVED]
« on: September 13, 2011, 04:32:52 PM »
I can't get Playmaker 1.2. The Asset store thinks I already have the latest one. It has an Import option and a Download and Reimport option. Trying that it says "Already Up To Date, Would you like to download anyway?" So I click Download and nothing happens. I thought my list of downloaded Assets would show that a new version is available, But it says mine is up to date. Clicking to Download anyway in there shows an error message.

It says in the Installation help page https://hutonggames.fogbugz.com/default.asp?W11 that I can install from a Unity package. So I was going to delete my local one and force it to download a new one but there's nothing on my computer called Playmaker.unitypackage.
« Last Edit: November 05, 2011, 12:07:34 PM by alexchouls »

tim.holman

  • 1.2 Beta
  • Playmaker Newbie
  • *
  • Posts: 49
    • View Profile
Re: Can't Download 1.2
« Reply #1 on: September 14, 2011, 08:47:46 AM »
I am having a similar problem. It was telling me I was already up to date, yet I was still using version 1.1.

Another thread suggested I "reimport all," then try to update to playmaker 1.2. So I tried that, but to no avail.

Once I downloaded it, it broke my project. I now have a long list of errors. Not only can I not play the game because of compiler errors, but Playmaker (along with several other extensions like Easy Roads) seemed to remove itslef from the project all together.

What to do?!?!?!

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3640
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Can't Download 1.2
« Reply #2 on: September 14, 2011, 09:53:29 AM »
I've emailed Unity about these problems and they've filed a bug on it...

I think there was a category mixup that's causing problems: the Visual Scripting category didn't exist when Playmaker 1.0 was first submitted, and now they're might be duplicate Playmaker entries. For example, when you make a new project, if you see 2 Playmaker packages, use the first one.

Are you able to import Playmaker into a new project from the asset store? If so, you could try importing Playmaker into a new project, then export the gizmos, itween, and playmaker folders in a unitypackage, then import that into your existing project.

Hopefully I'll get some answers back from Unity on how best to fix this problem!

FractalCore

  • 1.2 Beta
  • Junior Playmaker
  • *
  • Posts: 97
    • View Profile
Re: Can't Download 1.2
« Reply #3 on: September 14, 2011, 06:58:53 PM »
It might be more of general Unity question, but, how would I go about resetting the list of assets I've downloaded. It seems like if I could just trick Unity into thinking I'd never downloaded Playmaker, it would let me get the latest version. I guess re-installing Unity might be an answer but that seems a little extreme.

I'm keen to try out these new global variables.

FractalCore

  • 1.2 Beta
  • Junior Playmaker
  • *
  • Posts: 97
    • View Profile
Re: Can't Download 1.2
« Reply #4 on: September 15, 2011, 04:07:41 AM »
I managed to get it at home. I'd been trying at work. Not sure why it worked that way. Except that the work Unity was the second one I installed. If that's of any use. My home Unity is my primary one. Either way, I've got 1.2 now.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3640
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Can't Download 1.2
« Reply #5 on: September 15, 2011, 04:17:33 PM »
I heard back from Unity and they said they've fixed this, so the asset store should now download the newest version. So you might want to give it another shot... :)

FractalCore

  • 1.2 Beta
  • Junior Playmaker
  • *
  • Posts: 97
    • View Profile
Re: Can't Download 1.2
« Reply #6 on: September 15, 2011, 09:01:00 PM »
Looks like they've just done a major overhaul of the downloaded assets list on the Asset Store. But it still doesn't work. It even now lists it as Playmaker 1.1.1. Still won't update.

I've included a screen grab. This is after I clicked Download. You can see at the top, the error message that came up from a previous attempt.

However, like I said last time... I've downloaded it at home now. For some reason it worked there. So I'll try bringing those updated assets in for this copy.

cozmoziz

  • Playmaker Newbie
  • *
  • Posts: 1
    • View Profile
Re: Can't Download 1.2
« Reply #7 on: October 16, 2011, 09:20:28 PM »
I've had the same problem with trying to update from 1.1 to 1.2, did all the same steps mentioned above.  Then while I had the asset store window opened I noticed I wasn't logged in. I also clicked on the Toggle Download Manager icon in the top left of the asset store window.  This brought up all the packages I've downloaded in the past.  I noticed before I logged into the asset store that my Playmaker version was at 1.1.  Once I logged in the packages refreshed and Playmaker was now showing 1.2.1.  I re-downloaded Playmaker and now in the About it shows the latest version. 

Of course when I open a new project I have two Playmaker.unitypackages showing, and I don't know where the second is coming from, unless it is querying it from the asset store.  I did download Playmaker before they changed the category to Visual Scripting so maybe that has something to do with it.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3640
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Can't Download 1.2
« Reply #8 on: October 16, 2011, 09:25:11 PM »
Good to know about logging in! Was wondering why some people were having problems while others weren't.

The duplicate Playmaker.unitypackages comes from the new Visual Scripting category. The asset store guys have a bug open on this, but not sure when/if this will be fixed.

I believe the newest version is listed first...

clandestine

  • Sr. Member
  • ****
  • Posts: 254
    • View Profile
Re: Can't Download 1.2
« Reply #9 on: October 17, 2011, 07:37:14 AM »
the system was just fixed a couple of hours ago.