playMaker

Author Topic: ArrayMaker errors  (Read 2736 times)

Gua

  • Full Member
  • ***
  • Posts: 163
    • View Profile
    • Andrii Vintsevych
ArrayMaker errors
« on: February 10, 2015, 08:53:57 PM »
When I integrate ArrayMaker in my current project, I get those errors


jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14703
  • Official Playmaker Support
    • View Profile
Re: ArrayMaker errors
« Reply #1 on: February 16, 2015, 08:24:16 AM »
Hi,

 yeah, ok, tricky :) cause ArrayMaker maker is pending an update waiting for 1.8...

 reinstall the ugui package, it will update the outdated scripts again.

 Bye,

 Jean

Gua

  • Full Member
  • ***
  • Posts: 163
    • View Profile
    • Andrii Vintsevych
Re: ArrayMaker errors
« Reply #2 on: April 07, 2015, 01:58:15 AM »
Hi,

 yeah, ok, tricky :) cause ArrayMaker maker is pending an update waiting for 1.8...

 reinstall the ugui package, it will update the outdated scripts again.

 Bye,

 Jean
How can I properly upgrade it? Without the need to delete duplicate scripts.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14703
  • Official Playmaker Support
    • View Profile
Re: ArrayMaker errors
« Reply #3 on: April 07, 2015, 03:26:44 AM »
Hi,

 You can't unfortunatly. Unity 5 has a new way to deal with content imported from a UnityPackage, and so it doesn't recognize existing content on some cases and duplicate newly imported content, so everything renamed is actually newer.

If there is a way around this, I am willing to learn, but from my understanding the best way is to delete the content first and then reimport fresh to avoid renaming and cleaning up manually. PlayMaker package introduced a utility script that runs and clean this up, but it's obviously not practical to do this for every package on the wiki, unfortunatly.

so when I  have a folder exposing this problem, I delete the whole folder and re import the package and it works.

MAKE SURE YOU BACKUP WHEN UPGRADING and doing such manipulation.

Bye,

 Jean


Gua

  • Full Member
  • ***
  • Posts: 163
    • View Profile
    • Andrii Vintsevych
Re: ArrayMaker errors
« Reply #4 on: April 07, 2015, 03:47:48 AM »
Hi,

 You can't unfortunatly. Unity 5 has a new way to deal with content imported from a UnityPackage, and so it doesn't recognize existing content on some cases and duplicate newly imported content, so everything renamed is actually newer.

If there is a way around this, I am willing to learn, but from my understanding the best way is to delete the content first and then reimport fresh to avoid renaming and cleaning up manually. PlayMaker package introduced a utility script that runs and clean this up, but it's obviously not practical to do this for every package on the wiki, unfortunatly.

so when I  have a folder exposing this problem, I delete the whole folder and re import the package and it works.

MAKE SURE YOU BACKUP WHEN UPGRADING and doing such manipulation.

Bye,

 Jean

Here's what I do.

1. Delete Playmaker Custom Actions, Playmaker uGUI, Playmaker Utils folders.
2. Import latest version of uGUI package with custom actions.

Here's what I get
« Last Edit: April 07, 2015, 03:50:28 AM by Gua »

sebaslive

  • Hero Member
  • *****
  • Posts: 559
    • View Profile
    • Frame Tale Studios
Re: ArrayMaker errors
« Reply #5 on: April 07, 2015, 07:19:54 AM »
Hey Gua, is this from my package? If so, maybe I should add in any extra packages so that no gets any errors and complicate things.
All my VR games use Steam VR Playmaker Toolkit: http://u3d.as/u20
And Oculus Touch Playmaker Toolkit: http://u3d.as/QT5


Follow me @sebasRez

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14703
  • Official Playmaker Support
    • View Profile
Re: ArrayMaker errors
« Reply #6 on: April 07, 2015, 07:20:29 AM »
Hi,

 Sorry, bad packaging ( I know include all ui related custom actions, but I forgot one common file...). I repackaged. Can you redownload and import again, the errors will go away.

Bye,

 Jean