playMaker

Author Topic: No animations on object?  (Read 1191 times)

fletcherkildren

  • Playmaker Newbie
  • *
  • Posts: 19
    • View Profile
No animations on object?
« on: September 25, 2015, 05:41:54 PM »
Hi all!

I'm trying to wire up a simple FSM to open a door when you enter its box collider. I modeled and animated a simple door in Blender (30 frame animation 15 frames open, 15 close) split the clips in 2 when I imported it and am trying to wire a simple FSM on either / both of Hutongs YouTube tutorials - but when I go to select my animations in the "Play animation" action and it gives me a 'No animations on object' when I try to click on the up/down button next to Anim Name. I've done this with both a .blend file and a .fbx export to no avail. Using Unity 5.1.2f1. Yhanks!

mdotstrange

  • Hero Member
  • *****
  • Posts: 549
    • View Profile
    • Can't code? Who cares! Make games anyway!
Re: No animations on object?
« Reply #1 on: September 25, 2015, 07:42:32 PM »
"Play Animation" uses the legacy animation system which I've never used but I do use "Animator Play" which uses the newer animation system- and with that you can't pick the clip names you have to type them in manually so you might want to try typing the names in manually-
Indie game dev and instructor at the Strange School. Learn Playmaker at the Strange School!

fletcherkildren

  • Playmaker Newbie
  • *
  • Posts: 19
    • View Profile
Re: No animations on object?
« Reply #2 on: September 29, 2015, 11:14:03 AM »
OK! HALF the battle is won! Thanks for the legacy tip - that did the trick as far as the animation playing when the player enters the box collider, but now when I hit play, the door jumps halfway across the level and is rotated on its side - any ideas why THAT is?

mdotstrange

  • Hero Member
  • *****
  • Posts: 549
    • View Profile
    • Can't code? Who cares! Make games anyway!
Re: No animations on object?
« Reply #3 on: September 30, 2015, 01:16:38 AM »
It probably has some to do with world/local coordinates- animations in Unity get weird when you move/rotate objects around after animating them if they are not parented to another object-

So you can try making it a child of a null and resetting its transforms- it could also be Unity misinterpreting the imported animation- does the animation look right when you preview it from the imported fbx? If so its probably a coordinate issue
Indie game dev and instructor at the Strange School. Learn Playmaker at the Strange School!