playMaker

Author Topic: Unity 5.3 Compatibility  (Read 4875 times)

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3201
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Unity 5.3 Compatibility
« on: January 28, 2016, 11:24:57 AM »
IMPORTANT: Unity 5.3 users should install the 1.8.0 beta.
There are known issues with 1.7.8.4 and Unity 5.3 that are fixed in 1.8.

1.8 has been in beta for a while and is stable. We just wanted to release it as a public beta since it's a big update. It will become the official version very soon.

Import the latest version from the store, then install 1.8.0 from the Welcome Screen.

If the Welcome Screen doesn't open automatically you can find it here:
MainMenu > PlayMaker > Welcome Screen.

You can also find the PlayMaker.1.8.0.unitypackage in Assets\PlayMaker\Editor\Install.

As always, BACKUP your projects before updating! Projects saved with 1.8 cannot be opened in older versions of PlayMaker!
« Last Edit: January 28, 2016, 11:29:39 AM by Alex Chouls »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3201
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Unity 5.3 Compatibility
« Reply #1 on: February 06, 2016, 10:50:42 AM »
If you get this error in Unity 5.3.2 when pressing play in the editor:

Code: [Select]
InvalidOperationException: This cannot be used during play mode.
UnityEditor.SceneManagement.EditorSceneManager.MarkSceneDirty (Scene scene)

Please import the attached unitypackage. This patch will be in the next update.
« Last Edit: February 06, 2016, 10:52:34 AM by Alex Chouls »

jason statham

  • Playmaker Newbie
  • *
  • Posts: 1
    • View Profile
Re: Unity 5.3 Compatibility
« Reply #2 on: March 04, 2016, 05:18:57 AM »
Thanks it works!! ;)

doppelmonster

  • Full Member
  • ***
  • Posts: 157
    • View Profile
    • Grinder Games
Re: Unity 5.3 Compatibility
« Reply #3 on: June 12, 2016, 11:07:57 PM »
Hi Alex,
i just downloaded 1.81. Does that mean its final? I think you should create a upgrade guide for projects created with 1.7x. Which is about incompatibility, solutions and workarounds.
Or is there already some info I am misssing?

Thanks,
Matthias

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12342
  • Official Playmaker Support
    • View Profile
Re: Unity 5.3 Compatibility
« Reply #4 on: June 13, 2016, 03:35:47 AM »
Hi,

Yes, 1.8.1 is final.

 The upgrade guide is available within the Update checker editor window that is launched when you installed the package from the Asset store.

 The upgrade mainly affects new sets of actions that where previously available on the wiki and Ecosystem, now they are officialy distributed. This should not change or alter any of your existing projects, so the guide is really about cleaning up your project, however, since the guid are kept, even without cleaning, up things should go smoothly.

There is no know incompatibilities as far as I know.

 Let us know if there is some hickups, we'll assits.

 Always backup before upgrading is the most important part of a safe transition :)

Bye,

 Jean

Bye,

 Jean

Dan

  • Playmaker Newbie
  • *
  • Posts: 45
    • View Profile
    • Personal Site
Re: Unity 5.3 Compatibility
« Reply #5 on: July 28, 2016, 08:33:07 PM »
Hello,

I'm running 1.8.0 and when I run updater it states no updates needed. How do I get the most recent 1.8.1?

Thanks


5.3.5f1 Personal Edition
« Last Edit: August 02, 2016, 12:45:07 AM by Dan »

aa_lique

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: Unity 5.3 Compatibility
« Reply #6 on: July 31, 2016, 10:36:45 AM »
Hi Alex
Are both 1.8.0 and 1.8.1 compatible for 5.4?
Thanks
Angelique

paul.harden

  • Playmaker Newbie
  • *
  • Posts: 6
    • View Profile
Re: Unity 5.3 Compatibility
« Reply #7 on: August 02, 2016, 11:56:04 AM »
Hi,
I've just installed playmaker in a new 5.3.5 project and apparently a number of network actions are broken.
Any Clues?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12342
  • Official Playmaker Support
    • View Profile
Re: Unity 5.3 Compatibility
« Reply #8 on: August 29, 2016, 04:38:15 AM »
Hi,

 It's best to delete all networking actions, they are obsolete. The next version of PlayMaker should enforce better isolation of obsolete api for networking.

 Bye,

 Jean

paul.harden

  • Playmaker Newbie
  • *
  • Posts: 6
    • View Profile
Re: Unity 5.3 Compatibility
« Reply #9 on: August 29, 2016, 05:05:19 AM »
ok, thanks!

Sharm

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
    • best credit repair
Re: Unity 5.3 Compatibility
« Reply #10 on: October 05, 2016, 06:10:06 AM »
hello 8) 8) 8) 8) 8)