playMaker

Author Topic: Getting errors after update  (Read 2292 times)

Cratz

  • Playmaker Newbie
  • *
  • Posts: 21
    • View Profile
Getting errors after update
« on: August 11, 2016, 06:48:07 PM »
Cant see the playmaker menu at the top anymore, and it added new things like PlayMaker Utils,PlayMaker uGui, PlayMaker Custom Actions, and Have no clue what they are. Getting errors such as... Assets/PlayMaker Utils/Wizards/PlayMakerEventProxy/Editor/PlayMakerEventProxyCreatorWizard.cs(42,61): error CS0117: `EventType' does not contain a definition for `MouseMove'

That I didnt have before. What is going on??

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3207
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Getting errors after update
« Reply #1 on: August 11, 2016, 10:42:41 PM »
None of those folders should be part of the main Playmaker install, so they shouldn't be added when updating Playmaker. They were most likely added when you imported an add-on. Maybe you're only aware of them now because of the error? Any error in an editor script can cause other editor scripts (like the Playmaker editor) to not get compiled (so it doesn't appear in the menu).

I believe Jean will need to look into the PlayMakerEventProxyCreatorWizard error since he maintains that add-on. My guess, from the error, is that you imported another script that re-defines EventType in the global namespace overriding UnityEngine.EventType. Have you imported any other editor extensions recently?

If you're not using the Event Proxy Creator Wizard you could try deleting that file as a workaround for now.

« Last Edit: August 11, 2016, 10:45:10 PM by Alex Chouls »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12351
  • Official Playmaker Support
    • View Profile
Re: Getting errors after update
« Reply #2 on: August 12, 2016, 01:24:14 AM »
Hi,

 That's odd. I tried on 5.3 and 5.4 but this line doesn't cause any trouble.

 Which version of Unity are you using?

As Alex mentionned, none of this is part of PlayMaker asset package you downloaded from the Unity Asset store, so it was installed either from the wiki, the forum or the Ecosystem, or else it was already there in your project before you upgraded Unity.

Can you paste the first error you get in the Unity console, as well as the last error. Something else is playing funny which causes a chain reaction for other scripts to loose it.

 Bye,

 Jean

Cratz

  • Playmaker Newbie
  • *
  • Posts: 21
    • View Profile
Re: Getting errors after update
« Reply #3 on: August 12, 2016, 04:31:53 AM »
I'm using Unity version 5.3.5f1 personal

Cratz

  • Playmaker Newbie
  • *
  • Posts: 21
    • View Profile
Re: Getting errors after update
« Reply #4 on: August 12, 2016, 05:53:14 PM »
Another error -

Assets/PlayMaker/Editor/PlayMakerMainMenu.cs(19,17): error CS0103: The name `FsmEditorWindow' does not exist in the current context

Cratz

  • Playmaker Newbie
  • *
  • Posts: 21
    • View Profile
Re: Getting errors after update
« Reply #5 on: August 13, 2016, 03:46:17 PM »
The only thing I downloaded and added was this - https://hutonggames.fogbugz.com/?W1192

Provided by Zeldag

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3207
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Getting errors after update
« Reply #6 on: August 13, 2016, 08:19:34 PM »
I installed Playmaker and the Unity UI package and didn't get any errors.
Have you installed any other extensions or assets?
What platform are you building for?
What is the first error in the console? Often other errors stem from the first error. Fix the first one and it can fix the others...

Cratz

  • Playmaker Newbie
  • *
  • Posts: 21
    • View Profile
Re: Getting errors after update
« Reply #7 on: August 14, 2016, 11:49:12 AM »
Assets/PlayMaker Utils/Wizards/PlayMakerEventProxy/Editor/PlayMakerEventProxyCreatorWizard.cs(42,61): error CS0117: `EventType' does not contain a definition for `MouseMove'

Thats the first error I get. And I'm building for android.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3207
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Getting errors after update
« Reply #8 on: August 14, 2016, 03:32:31 PM »
Again this sounds like another script has re-defined EventType in the global namespace.

Can you search your project for an EventType class? First just search in the project view for "EventType" then use Monodevelop or Visual Studio to find in files "class EventType".

You can also open PlayMakerEventProxyCreatorWizard.cs and replace EventType with UnityEngine.EventType to confirm if that is the problem.

Cratz

  • Playmaker Newbie
  • *
  • Posts: 21
    • View Profile
Re: Getting errors after update
« Reply #9 on: August 14, 2016, 05:41:06 PM »
Okay so I searched in project for "EventType" came up with nothing.

Then I replaced EventType With UnityEngine.EventType. Which after I did that the particular one gave me no errors.

Then I tried to Play the game and got hit with another error.


Cratz

  • Playmaker Newbie
  • *
  • Posts: 21
    • View Profile
Re: Getting errors after update
« Reply #10 on: August 14, 2016, 05:42:10 PM »
this is with error

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3207
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Getting errors after update
« Reply #11 on: August 14, 2016, 08:33:32 PM »
This means there is definitely another script in your project that has re-defined EventType in the global namespace. This is a very bad idea since EventType is a UnityEngine type.

If you didn't write this script, it was included in an asset you imported.

Quote
Okay so I searched in project for "EventType" came up with nothing.

You need to use some kind of find in files in Monodevelop, Visual Studio, or another text editor; file explorer might even work. But you have to find the source file that has re-defined EventType (e.g. it will have something like "public class EventType"). Once you find the file it should be obvious which asset it was part of. If you're not using the asset you can delete it, otherwise you should email the author to fix it.




Cratz

  • Playmaker Newbie
  • *
  • Posts: 21
    • View Profile
Re: Getting errors after update
« Reply #12 on: August 15, 2016, 02:29:03 PM »
Okay so after a lot of digging I found the culprit, it was an asset I downloaded which after I delete it, the  game ran with no error. But what was weird  is that when I deleted all the assets scripts, it still threw the error. Which was weird, so I think something else is conflicting from that asset. Any ideas?

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3207
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Getting errors after update
« Reply #13 on: August 15, 2016, 03:19:15 PM »
Are you sure you deleted all the scripts that came with the asset? Sometimes scripts can be under plugins, or in a dll. Check against the original unitypackage/install to find all files.