playMaker

Author Topic: [SOLVED] Game Works in Unity but Not in Build  (Read 7376 times)

acornbringer

  • Playmaker Newbie
  • *
  • Posts: 36
    • View Profile
    • Acornbringer.com
Re: [SOLVED] Game Works in Unity but Not in Build
« Reply #15 on: November 29, 2016, 03:33:00 PM »
I don't get emails when people reply to my posts for some reason so I lost track of this post.

Just to reiterate, when I build the game while it is running, this solves my problem.

I see there are others having similar issues with gui and perhaps other things so I can't speak for those circumstances but running the game right before building works for MOUSE DOWN events and colliders.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14014
  • Official Playmaker Support
    • View Profile
Re: [SOLVED] Game Works in Unity but Not in Build
« Reply #16 on: December 01, 2016, 12:50:26 AM »
Hi,

 ok, very odd indeed. Are these object prefab instances?

Bye,

 Jean

acornbringer

  • Playmaker Newbie
  • *
  • Posts: 36
    • View Profile
    • Acornbringer.com
Re: [SOLVED] Game Works in Unity but Not in Build
« Reply #17 on: December 01, 2016, 08:29:14 AM »
They are Unity primitive shapes with SFMs on them that detect the MOUSE DOWN event but the mesh renderer has been turned off. They are not prefab instances, just scene objects. I haven't tried an updated version of Playmaker yet so I can't say if this is changed with new releases of either Unity or Playmaker.

I'm working in Unity 5.3.6 and still using Playmaker 1.8.1. Running the game before building has been working out just fine though.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14014
  • Official Playmaker Support
    • View Profile
Re: [SOLVED] Game Works in Unity but Not in Build
« Reply #18 on: December 14, 2016, 12:07:26 AM »
Hi,

 Can you make another post, this one was solved, it was a setup of the scene that made it work only in editor.

 Bye,

 Jean

Panskliros

  • Playmaker Newbie
  • *
  • Posts: 1
    • View Profile
Re: [SOLVED] Game Works in Unity but Not in Build
« Reply #19 on: March 02, 2017, 07:33:41 AM »
I have the exact same issue. Any fix?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14014
  • Official Playmaker Support
    • View Profile
Re: [SOLVED] Game Works in Unity but Not in Build
« Reply #20 on: March 05, 2017, 10:58:55 PM »
Hi,

It's likely a problem of logic inside your Fsms, and not a  PlayMaker Bug.

 Make a simple scene with a cube, and test a single feature, the mouse down for example, if that works, then you'll need to compare this with your other scene and setup. I know, it's a pain, but we all have to go through this... You could do some logs as well in the state you think you are reaching or not reaching to make sure of where you are when built.

Bye,

 Jean