playMaker

Author Topic: I get 999+ errors when I try to build for Tizen [SOLVED]  (Read 121 times)

gabba

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
I get 999+ errors when I try to build for Tizen [SOLVED]
« on: August 29, 2017, 07:07:24 AM »
Hi guys,
whenever I try to build for Tizen OS i get 999+ errors (as you can see in the image). When I play the game with the Tizen platform switched (before trying to make the build) everything works perfectly but when I try to make the build I get the errors and it's like Playmaker is not installed anymore. I lose all the Playmaker scripts, tabs, windows, etc.
I tried to modify the .dlls in the Plugins\Playmaker folder adding Tizen but with no result.
I hope someone can help me.


Thank you
« Last Edit: August 30, 2017, 03:23:16 PM by Alex Chouls »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3181
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: I get 999+ errors when I try to build for Tizen
« Reply #1 on: August 29, 2017, 08:03:18 AM »
Hi, this thread should help:
http://hutonggames.com/playmakerforum/index.php?topic=10893.msg63918

You need to configure the plugins, but also add a scripting define symbol, as described in that thread.


gabba

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
Re: I get 999+ errors when I try to build for Tizen
« Reply #2 on: August 29, 2017, 08:11:02 AM »
Thanks for the quick reply. I read about the "scripting define symbol" but I can see no "Configuration" button under "build settings"...

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3181
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: I get 999+ errors when I try to build for Tizen
« Reply #3 on: August 29, 2017, 12:51:30 PM »
It's in Build Settings > Player Settings > Other Settings > Configuration

Sorry about that. Not sure if it moved or if the initial directions were bad...

gabba

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
Re: I get 999+ errors when I try to build for Tizen
« Reply #4 on: August 30, 2017, 03:48:59 AM »
Thank you very much! I tried to add "UNITY_NACL;" to the "scripting define symbol" textbox and now, after I try to make the build, I get 3 errors...

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3181
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: I get 999+ errors when I try to build for Tizen
« Reply #5 on: August 30, 2017, 12:06:30 PM »
Go through the Playmaker dlls in Plugins and make sure only one is checked for Tizen. This might mean unchecking Any.

gabba

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
Re: I get 999+ errors when I try to build for Tizen
« Reply #6 on: August 30, 2017, 02:22:42 PM »
Ok. Previously I checked Tizen in all the .dlls and I suppose that was the problem. Now I only checked it in the main Playmaker.dll. Furthermore I added the string "UNITY_WEBGL;" to the previously added "UNITY_NACL;" string and it works perfectly.
Thank you very much for your support, really appreciated.