playMaker

Author Topic: Looks like a disaster  (Read 279 times)

thierry_st_malo

  • Junior Playmaker
  • **
  • Posts: 58
    • View Profile
Looks like a disaster
« on: July 12, 2018, 06:22:25 AM »
I'm facing what looks like a total PlayMaker disaster. Having changed my PC, I have reloaded PlayMaker from the Asset Store and got 1.9.1. It seems to be totally incompatible with just about everything. I had two nice games I was happy about and which ran nicely in 2017 : full incompatibility ( red message from the console, textures unrecognized, etc. ). I had used the "Car setup for Playmaker" ( Asset Store ) and I reloaded it : full incompatibility. Out of curiosity I reloaded your Sample Scenes : full incompatibility. I think I'll switch to Bolt, which runs correctly.

I use Unity 2018.1.4f1. And I am extremely unhappy.

600

  • Beta Group
  • Hero Member
  • *
  • Posts: 579
    • View Profile
    • Car and Traffic Playmaker assets
Re: Looks like a disaster
« Reply #1 on: July 12, 2018, 06:46:12 AM »
Playmaker staff will be able to help if you could post errors you have in the console.
Any update can brake stuff, not Playmaker alone it goes to all plugins, even Bolt.

Regards the Car Setup, the compatible version for Unity 2018 and PM 1.9+ is pending in Asset Store review, I submitted it more than 2 weeks ago. But in general it needs just updated Playmaker Utils, found here:
- Download Utils as zip here (green button “Clone or download”) https://github.com/jeanfabre/PlayMaker--Utils
- Delete the old Utils folder, check in Car Setup’s folder too, Unzip and rename the folder to “Playmaker Utils” and place it in your project.
- Accept to update API, wait for Unity to compile (loading icon bottom right corner).

This will fix Car Setup compatibility, I can not comment about other plugins or errors you have.
Remember to create backups when you upgrade versions.
Hope this helps.

thierry_st_malo

  • Junior Playmaker
  • **
  • Posts: 58
    • View Profile
Re: Looks like a disaster
« Reply #2 on: July 12, 2018, 08:14:56 AM »
Thanks, 600.

But : "Any update can brake stuff, not Playmaker alone it goes to all plugins, even Bolt." With my 40 years of experience as a developer (yes, forty)
I know that, thank you. Actually, this is a classic case of ... (we know what).

If people are interested:

"The script 'PlayMakerGlobals' does not derive from MonoBehaviour, but has been added to Game Object 'PlayMakerGlobals'. Please remove the script from the Game Object to avoid crashes."

Assets/PlayMaker/Actions/ProceduralMaterial/RebuildTextures.cs(45,56): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'

 I will admit that incessant changes in Unity's API are a pain, though.



westingtyler

  • Full Member
  • ***
  • Posts: 186
    • View Profile
    • My Oculus Rift + Touch VR Game Using Playmaker
Re: Looks like a disaster
« Reply #3 on: July 12, 2018, 08:30:49 AM »
I had the Substance Designer errors as well when I upgraded. I went into the offending scripts, did Control-F and found the if-then statements, etc. that included the procedural material words, then commented them out with, like,  // before each line. then saved. then those procedural errors went away.

I don't even use Substance Designer. if you do and can't just comment these out, I'd definitely try asking the Substance or Unity people. I think Substance has some importer on their web site, which i was going to get to convert stuff before I realized I've never used Substance. I'm more upset by my shader forge shaders no longer working since Shader Forge ended updates, but I can rebuild them faster and better using Shader Graph. It'll be good exercise for me, but I only have like 12.

Playmaker is an amazing tool that has changed my career path to game developer. It has great and responsive support. I've only used it/been a gamedev for four years at this point, and in that time I've been fortunate that the Playmaker devs could easily help when I've had upgrade errors. They've helped me learn quite fast, and I even learned for myself how to comment out the six or so lines of code to fix the Substance errors.

I recommend Playmaker to everyone. I may try out Bolt someday, but I don't know what it could offer that Playmaker hasn't already offered. Maybe I'm just naive, lol. But I couldn't ask for a better support team.


thierry_st_malo

  • Junior Playmaker
  • **
  • Posts: 58
    • View Profile
Re: Looks like a disaster
« Reply #4 on: July 12, 2018, 09:50:18 AM »
@600:

I tried to fix "Car Setup" and apparently made a mess of it. As soon as the new version is available, please let me know.

Thanks in advance.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13321
  • Official Playmaker Support
    • View Profile
Re: Looks like a disaster
« Reply #5 on: July 30, 2018, 03:32:29 AM »
Hi,

 did you get a resolution on this?

 Bye,

 Jean

600

  • Beta Group
  • Hero Member
  • *
  • Posts: 579
    • View Profile
    • Car and Traffic Playmaker assets
Re: Looks like a disaster
« Reply #6 on: August 06, 2018, 06:20:02 AM »
@600:

I tried to fix "Car Setup" and apparently made a mess of it. As soon as the new version is available, please let me know.

Thanks in advance.
The version for Unity 2018 and Playmaker 1.9+ is available in Asset Store.