playMaker

Author Topic: Unity 5 compatibility ?  (Read 7442 times)

app_advisory

  • Junior Playmaker
  • **
  • Posts: 80
    • View Profile
    • App Advisory
Unity 5 compatibility ?
« on: October 27, 2014, 02:52:08 AM »
Hi,

I tried Unity 5. There is a lot of issue.

Do you plan to upgrade the 1.7.7.2 ?

Thanks a lot !

Lane

  • Administrator
  • Hero Member
  • *****
  • Posts: 2484
  • Yup.
    • View Profile
    • Cleverous
Re: Unity 5 compatibility ?
« Reply #1 on: October 27, 2014, 04:23:24 AM »
In Unity 5 there are a few big API changes, but they created an automatic API updater that goes through your scripts and corrects the broken code. It's not ideal, but it does fix the errors.

I'm pretty sure Alex plans to update the built in actions to accommodate for this in 1.8.0 if he hasn't already. The 1.8 beta works great in Unity 5 and is close to release.

app_advisory

  • Junior Playmaker
  • **
  • Posts: 80
    • View Profile
    • App Advisory
Re: Unity 5 compatibility ?
« Reply #2 on: October 27, 2014, 11:27:26 AM »
Great ! Thanks !

I bought via your website "Playmaker", how can I know when the update will be available ?

Thanks a lot !

terri

  • Sr. Member
  • ****
  • Posts: 348
    • View Profile
    • terrivellmann.tumblr.com
Re: Unity 5 compatibility ?
« Reply #3 on: October 27, 2014, 12:05:23 PM »
In Unity 5 there are a few big API changes, but they created an automatic API updater that goes through your scripts and corrects the broken code. It's not ideal, but it does fix the errors.

I'm pretty sure Alex plans to update the built in actions to accommodate for this in 1.8.0 if he hasn't already. The 1.8 beta works great in Unity 5 and is close to release.

cool, can't wait! unity 5 looks pretty sweet

xhidnoda

  • Full Member
  • ***
  • Posts: 231
    • View Profile
Re: Unity 5 compatibility ?
« Reply #4 on: October 27, 2014, 12:19:47 PM »
how can I know when the update will be available ?

Lane

  • Administrator
  • Hero Member
  • *****
  • Posts: 2484
  • Yup.
    • View Profile
    • Cleverous
Re: Unity 5 compatibility ?
« Reply #5 on: October 27, 2014, 12:22:52 PM »
There will be an announcement post about it. =)

app_advisory

  • Junior Playmaker
  • **
  • Posts: 80
    • View Profile
    • App Advisory
Re: Unity 5 compatibility ?
« Reply #6 on: October 27, 2014, 01:38:41 PM »
:) great

xhidnoda

  • Full Member
  • ***
  • Posts: 231
    • View Profile
Re: Unity 5 compatibility ?
« Reply #7 on: November 06, 2014, 06:54:30 AM »
Nothing yet?

Kubold

  • Junior Playmaker
  • **
  • Posts: 99
    • View Profile
Re: Unity 5 compatibility ?
« Reply #8 on: February 09, 2015, 11:57:32 AM »
So... Unity sent an e-mail today saying "get your Asset Store stuff ready for Unity 5 NOW. Or else!".

The problem is all my Asset Store packages require PlayMaker to work. Will you be ready with 1.8 soon? I can already see the sh... storm coming my way from buyers, if you aren't :D. I guess you recieved similar e-mail from Unity.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12342
  • Official Playmaker Support
    • View Profile
Re: Unity 5 compatibility ?
« Reply #9 on: February 19, 2015, 02:33:17 AM »
Hi,

 Unity 5 being still a beta, it's dangerous to release a PlayMaker right now ( my personal opinion here, I do't know when 1.8 will go out).

I understand Unity is pushing for everyone to move to 5, It's a marketing strategy more than the best move you should do as a developer really... but I personally won't. The Main raison being moving sensitive project to x.0 in general is gambling with failure and frustration, it's always good to wait to the first patch or minor update like 5.1 for example, it was the same with Unity 4...

But I am confident that once Unity 5 is out for real, PlayMaker will release almost immediately an update, if not sooner.

 Bye,

 Jean

allornothing

  • Playmaker Newbie
  • *
  • Posts: 17
    • View Profile
Re: Unity 5 compatibility ?
« Reply #10 on: March 03, 2015, 10:48:47 AM »
Now that its out in the wild, is there any info on current support / future support? Very interested in looking at new features, but not if playmaker falls down :)

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3202
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Unity 5 compatibility ?
« Reply #11 on: March 03, 2015, 10:59:15 AM »
We just released a 1.7.8 update for full Unity 5 compatibility :)

lukew

  • Playmaker Newbie
  • *
  • Posts: 16
    • View Profile
Re: Unity 5 compatibility ?
« Reply #12 on: March 03, 2015, 11:16:44 AM »
Awesome!

What about Unity Action Packs? I'm mostly interested in Pathfinding and Mecanim actions. Are they included in the update?

If not, do you recommend to use the old ones and just let Unity 5 update them?

allornothing

  • Playmaker Newbie
  • *
  • Posts: 17
    • View Profile
Re: Unity 5 compatibility ?
« Reply #13 on: March 03, 2015, 11:44:50 AM »
My download link still points to 1.7.7.2 - how do I get the latest?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12342
  • Official Playmaker Support
    • View Profile
Re: Unity 5 compatibility ?
« Reply #14 on: March 04, 2015, 12:44:51 AM »
Hi,

 Did you purchasd via fastSpring or the asset store?

actions packs will work, I am aware that the mecanim package will warn about some obsolete actions, but this isn't a problem and it will work, I'll provide an update. Let me know how the pathfinding package works.


 Bye,

 Jean