playMaker

Author Topic: Unity 5.1.1 errors  (Read 8067 times)

wheretheidivides

  • Sr. Member
  • ****
  • Posts: 496
    • View Profile
Unity 5.1.1 errors
« on: June 30, 2015, 10:34:03 PM »
I get the following errors.  I a using unity 5.1.1p2 with windows 8.1.  I just downloaded newest playmaker.

Assets/PlayMaker/Actions/iTween/iTweenLookFrom.cs(30,24): warning CS0436: The type `iTween' conflicts with the imported type `iTween'. Ignoring the imported type definition

Assets/PlayMaker/Actions/Network/PlayMakerRPCProxy.cs(14,6): warning CS0618: `UnityEngine.RPC' is obsolete: `NetworkView RPC functions are deprecated. Refer to the new Multiplayer Networking system.'

Assets/PlayMaker/Actions/Network/SendRemoteEvent.cs(54,45): warning CS0618: `UnityEngine.NetworkView.RPC(string, UnityEngine.RPCMode, params object[])' is obsolete: `NetworkView RPC functions are deprecated. Refer to the new Multiplayer Networking system.'

Assets/PlayMaker/Actions/Network/SendRemoteEvent.cs(58,45): warning CS0618: `UnityEngine.NetworkView.RPC(string, UnityEngine.RPCMode, params object[])' is obsolete: `NetworkView RPC functions are deprecated. Refer to the new Multiplayer Networking system.'

Assets/PlayMaker/Actions/Network/SendRemoteEventByProxy.cs(54,29): warning CS0618: `UnityEngine.NetworkView.RPC(string, UnityEngine.RPCMode, params object[])' is obsolete: `NetworkView RPC functions are deprecated. Refer to the new Multiplayer Networking system.

Assets/PlayMaker/Actions/Network/SendRemoteEventByProxy.cs(54,29): warning CS0618: `UnityEngine.NetworkView.RPC(string, UnityEngine.RPCMode, params object[])' is obsolete: `NetworkView RPC functions are deprecated. Refer to the new Multiplayer Networking system.

Assets/PlayMaker/Editor/AboutWindow.cs(37,13): warning CS0618: `UnityEditor.EditorWindow.title' is obsolete: `Use titleContent instead (it supports setting a title icon as well).'

Assets/PlayMaker/Editor/PlayMakerUpgradeGuide.cs(38,20): warning CS0618: `UnityEditor.EditorWindow.title' is obsolete: `Use titleContent instead (it supports setting a title icon as well).'

Assets/net.fabrejean/Editor/PlayMaker/Ecosystem/EcosystemBrowser.cs(150,34): warning CS0618: `UnityEditor.EditorWindow.title' is obsolete: `Use titleContent instead (it supports setting a title icon as well).'



jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14595
  • Official Playmaker Support
    • View Profile
Re: Unity 5.1.1 errors
« Reply #1 on: June 30, 2015, 10:56:53 PM »
Hi,

 Can you install the Nacl version fo PlayMaker, this will get rid of the Network issues.

for iTween, I am not sure, could be that you installed itween separatly and now you have duplicates, and/or you upgraded from Unity 4 and reimporting PlayMaker duplicated iTween ( you would have "iTween 1.cs" in your assets).

as for the other warnings, the future versions of ecosystem and PlayMaker will adjust this, nothing to worry about.

Bye,

 Jean

wheretheidivides

  • Sr. Member
  • ****
  • Posts: 496
    • View Profile
Re: Unity 5.1.1 errors
« Reply #2 on: July 01, 2015, 12:57:53 PM »
what is  Nacl?

EdwardS

  • Playmaker Newbie
  • *
  • Posts: 1
    • View Profile
Re: Unity 5.1.1 errors
« Reply #3 on: July 01, 2015, 02:47:11 PM »
I've just upgraded my project to Unity 5.1.1f1 and I'm receiving an identical list of network errors.

I'm using Playmaker version 1.7.8.3

I can't seem to find a nacl version of Playmaker, or a folder called 'versions'.

Any help would be appreciated.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14595
  • Official Playmaker Support
    • View Profile
Re: Unity 5.1.1 errors
« Reply #4 on: July 02, 2015, 05:54:02 AM »
Hi,

Nacl definition

 PlayMaker provides several versions depending on the platform or distribution. It's in the folder:

PlayMaker/Versions/

and the file is "PlaymakerNACL"

run this and it will install a version that has it's built in network support removed.

Bye,

 Jean

wheretheidivides

  • Sr. Member
  • ****
  • Posts: 496
    • View Profile
Re: Unity 5.1.1 errors
« Reply #5 on: July 02, 2015, 10:37:19 AM »
I don't see this folder anywhere in the project window.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14595
  • Official Playmaker Support
    • View Profile
Re: Unity 5.1.1 errors
« Reply #6 on: July 02, 2015, 12:28:17 PM »
Hi,

 ok, weird indeed. I have contacted Alex, cause I am sure why it's not there. I was assuming it would be there. Sorry about the confusion.

Bye,

 Jean

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14595
  • Official Playmaker Support
    • View Profile
Re: Unity 5.1.1 errors
« Reply #7 on: July 02, 2015, 12:38:47 PM »
Hi,

 ok, so indeed in Unity 5, Nacl support is gone, so you'll need to use the WebGL version of PlayMaker. It's in Assets/Plugins/PlayMaker/WebGL/

Configure that version of PlayMaker to be selected for your platform ( not just WebGL), and then it will be ok.

Bye,

 Jean

wheretheidivides

  • Sr. Member
  • ****
  • Posts: 496
    • View Profile
Re: Unity 5.1.1 errors
« Reply #8 on: July 03, 2015, 11:25:03 AM »
and how do you do that?

Ony

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Re: Unity 5.1.1 errors
« Reply #9 on: July 17, 2015, 03:41:17 PM »
Yes, what does this mean please? "Configure that version of PlayMaker to be selected for your platform ( not just WebGL), and then it will be ok."

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14595
  • Official Playmaker Support
    • View Profile
Re: Unity 5.1.1 errors
« Reply #10 on: July 20, 2015, 04:02:47 AM »
Hi,

 this is the new way for Unity 5 to set up dlls for the various platforms.

http://docs.unity3d.com/Manual/PluginInspector.html

for each dll you can tell Unity for which platform is has to be enabled or disabled. and so you go to the plugins folder and selec the folder PlayMaker/WebGL/ and select the file "PlayMaker" and set it up to work for the platform you want to target, not just webgl, and you also do that for the main playmaker dll in folder Plugins/PlayMaker/ and disable that one from your platform target.

Does that make more sense?

Bye,

 Jean