playMaker

Author Topic: Photon actions error, help please  (Read 2392 times)

Ateam

  • Full Member
  • ***
  • Posts: 116
    • View Profile

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15494
  • Official Playmaker Support
    • View Profile
Re: Photon actions error, help please
« Reply #1 on: September 05, 2016, 04:00:47 AM »
Hi,

--  what version of Unity, PlayMaker and PUN are you using and what platform are you targeting?

-- Do you get this error when publishing or when developing?

-- If you start a fresh project, import PlayMaker, and PUN/PlayMaker, does it work?

Bye,

 Jean

Ateam

  • Full Member
  • ***
  • Posts: 116
    • View Profile
Re: Photon actions error, help please
« Reply #2 on: September 05, 2016, 10:37:49 AM »
Hi

I am using the 5.4p2 unity version , the playmaker 1.8.2 and the last version of PUN from here https://hutonggames.fogbugz.com/default.asp?W928 , when I start a new project  and import the PUN,  doesn't work.

« Last Edit: September 05, 2016, 11:06:38 AM by Ateam »

Ateam

  • Full Member
  • ***
  • Posts: 116
    • View Profile
Re: Photon actions error, help please
« Reply #3 on: September 05, 2016, 04:39:40 PM »
The problem is fixed now with the 5.3 unity version but, I can't find the photon events.
« Last Edit: September 05, 2016, 04:42:35 PM by Ateam »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15494
  • Official Playmaker Support
    • View Profile
Re: Photon actions error, help please
« Reply #4 on: September 06, 2016, 02:38:16 AM »
Hi,

 you need to drop the photon proxy prefab inside the scene to "register" the set of global events for Photon.

 Bye

Jean

IdeaScatter

  • Playmaker Newbie
  • *
  • Posts: 1
    • View Profile
Re: Photon actions error, help please
« Reply #5 on: September 09, 2016, 09:02:28 AM »
Hi Iam a new user of PlayMaker and I been having the same problem from day one.
(error: Unhandled Exception: System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.) Every time I download the latest version of Photon on ecosystem. I even try dragging the Photon Proxy prefab into the scene but it doesn't work either. I was wondering if any one can help. Im currently running on Unity 5.4, PlayMaker 1.8.3 and Photon unity 5 version 1.71  :'(

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15494
  • Official Playmaker Support
    • View Profile
Re: Photon actions error, help please
« Reply #6 on: September 26, 2016, 04:53:43 AM »
Hi,

 Are you downloading the Photon for Unity 5? there atwo version on the ecosystem, one for Unity 4 and one for Unity 5. Make sure you get the right one!

for Unity 5, you need to download photon from the asset store first and then download the package from the Ecosystem.

Bye,

 Jean