playMaker

Author Topic: Importing Globals From Unity5 to Unity 4.6  (Read 1842 times)

iEpic

  • Playmaker Newbie
  • *
  • Posts: 48
    • View Profile
    • IndieGamerWorld
Importing Globals From Unity5 to Unity 4.6
« on: November 15, 2016, 09:45:14 AM »
I've been working hard getting an asset store package that uses playmaker ready for release, but I'm having problems getting the global variables to import into Unity4.6.3f1
I created the project with Unity5.4 and exported the globals with that.
When I try to import them in Unity4.6.3 it says it couldn't decompress the package and there are no globals to import.





Does anyone know what I'm doing wrong??
Thanks in advance for anyone who can help me out.

iEpic

  • Playmaker Newbie
  • *
  • Posts: 48
    • View Profile
    • IndieGamerWorld
Re: Importing Globals From Unity5 to Unity 4.6
« Reply #1 on: November 15, 2016, 04:23:30 PM »
I've been working on this all day since I posted this, and still cannot get it to work.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Re: Importing Globals From Unity5 to Unity 4.6
« Reply #2 on: November 16, 2016, 01:34:00 AM »
Hi,

 you need to work the other way around.

 Work with the lowest possible verson of Unity ( 4.7) and thing will be compatible, the otherway is not possible,

 or do two or more packages, one for 4.7 and one for 5 and up.

I strongly advice NOT to use global variables when you publish packages, create a project that doesn't need it, it will be a lot simpler to deploy.

If you need tricks on avoiding global variables, let me know, I can hint you in several directions.

 Bye,

 Jean

iEpic

  • Playmaker Newbie
  • *
  • Posts: 48
    • View Profile
    • IndieGamerWorld
Re: Importing Globals From Unity5 to Unity 4.6
« Reply #3 on: November 16, 2016, 08:21:27 AM »
is 4.7 the lowest I can go, or can I do 4.6.3?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Re: Importing Globals From Unity5 to Unity 4.6
« Reply #4 on: November 17, 2016, 12:16:35 AM »
Hi,

 I advice not go under 4.7. It's also very likely soon assets will only support 5.x and up, so supporting less than 4.6 doesn't really make sense.

can you explain why you want to support 4.6?

Bye,

 Jean


iEpic

  • Playmaker Newbie
  • *
  • Posts: 48
    • View Profile
    • IndieGamerWorld
Re: Importing Globals From Unity5 to Unity 4.6
« Reply #5 on: November 17, 2016, 08:54:32 AM »
I wanted it to work for people who haven't updated to Unity 5 yet.

I was working on a project for 2 years and tried to upgrade to Unity 5 a couple of times and it completely broke the 2d physics and everything, and was too much of a hassle so I just stuck with Unity 4. I only just recently last month took the time to upgrade it to Unity 5. I'm sure there are other people in the same situation, I just wanted my asset to work for them too.

I just submitted my package for review with Unity5.0.0f4

Should i also upload it with another version, or will that be ok?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Re: Importing Globals From Unity5 to Unity 4.6
« Reply #6 on: November 17, 2016, 11:47:40 PM »
Hi,

 It depends what's in it really, since 5.0 a lot has changed and got deprecated, so I can't say for sure if your package will work on all iterations of 5.

Distributing to the asset store got very complex because of the various Unity versions, that's a fact. To support all the community work and ecosystem, etc etc, I have a dozen of Various Unity versions installed on my computer



and even like that sometimes I miss some deprecated functions during testing and all..

If you have already submitted, then fine, you'll see with feedback if all is well. Chances are 95% of people will use 5.3+ so you should be fine.

Good luck with this! let us know when it's out so we can promote it.

Bye,

 Jean