playMaker

Author Topic: uGUI debug showing "state 1" on click[SOLVED]  (Read 1679 times)

MattyWS

  • Junior Playmaker
  • **
  • Posts: 90
uGUI debug showing "state 1" on click[SOLVED]
« on: February 28, 2018, 08:37:47 AM »
Hi, has anyone else had an issue where a 'state 1' debug label would show up in the center of the scene when a uGui button is clicked on using "OnClick"? I have 3 buttons at the end of my level and they all do this despite none of my playmaker actions in the whole game having a state1 (I name them all). I doubled checked as well.

Any ideas? I have a Playmaker UGui prefab in the scene and the buttons have the "Play Maker u Gui Component Proxy (script)" component on them.

On top of that, all my playmaker FSM's have debug off
« Last Edit: March 07, 2018, 04:50:10 AM by jeanfabre »

MattyWS

  • Junior Playmaker
  • **
  • Posts: 90
Re: uGUI debug showing "state 1" on click
« Reply #1 on: February 28, 2018, 09:04:11 AM »
Infact, I found the culprit and it was a "playMaker Send Event Proxy" object made at run time... Screenshot below. How am I supposed to disable the debug labels on that? :(


jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15500
  • Official Playmaker Support
Re: uGUI debug showing "state 1" on click
« Reply #2 on: March 01, 2018, 03:57:04 AM »
Hi,

 I think you found the preference setting for this right?

 Bye,
 
Jean

MattyWS

  • Junior Playmaker
  • **
  • Posts: 90
Re: uGUI debug showing "state 1" on click
« Reply #3 on: March 01, 2018, 04:10:46 AM »
I didn't  find any preferences for this, is this fsm stored somewhere in the project? I didn’t think to change it to debug off in the scene while the game was running since next time I run it, it’d be a new one I assume.

So my issue still remains :(
« Last Edit: March 01, 2018, 06:17:46 AM by MattyWS »

MattyWS

  • Junior Playmaker
  • **
  • Posts: 90
Re: uGUI debug showing "state 1" on click
« Reply #4 on: March 01, 2018, 07:49:15 AM »
Oh I see what you mean now, I found the checkbox to disable labels. Blonde moment for me sorry! It's on the PlayMakerGUI object in the scene. This topic is resolved.