playMaker

Author Topic: Correct way to upgrade from 2017 to 2018  (Read 565 times)

nFighter

  • Beta Group
  • Full Member
  • *
  • Posts: 138
    • View Profile
    • multiplayer adult fighting
Correct way to upgrade from 2017 to 2018
« on: November 20, 2018, 12:48:47 PM »
I'm sticking with 2017.4 LTS but gave a try to upgrade on  2018.2:
1) updated playmaker to the latest version
2) open that project with 2018.2

...and, it was not going well. Playmaker menu disappear, somehow playmaker keep persist in a project, but the FSM's was referenced to "not found" objects, I got millions warnings and so on. I try to reinstall PM and ecosystem, but had no success. 

So, what is the correct way to upgrade the project from 2017 to 2018?
indie developer of multiplayer adult fighting
http://nakedfighter3d.com

NinjaX

  • Full Member
  • ***
  • Posts: 108
  • XCO is the ULTIMATE IOS Ninja!!
    • View Profile
    • XCOGAMES
Re: Correct way to upgrade from 2017 to 2018
« Reply #1 on: November 20, 2018, 03:29:31 PM »
From my personal experience there is no one way, and in some cases Ive had to either completely rebuild the game (port) or exports componets one at a time and see if they are ok.

Maybe someone will be able to give you a better option, sorry bro. Also really DIGGING your game!! 
XCO is the ULTIMATE IOS Ninja, Beware for he sees Everything and Nothing all at once!

3d_Artist1987

  • Beta Group
  • Full Member
  • *
  • Posts: 157
    • View Profile
Re: Correct way to upgrade from 2017 to 2018
« Reply #2 on: November 20, 2018, 09:27:23 PM »
I Also faced same isuue.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14316
  • Official Playmaker Support
    • View Profile
Re: Correct way to upgrade from 2017 to 2018
« Reply #3 on: November 20, 2018, 11:16:07 PM »
Hi,

 what are the errors you have?

Bye,

 Jean

nFighter

  • Beta Group
  • Full Member
  • *
  • Posts: 138
    • View Profile
    • multiplayer adult fighting
Re: Correct way to upgrade from 2017 to 2018
« Reply #4 on: February 09, 2019, 05:40:19 AM »
I'm trying to upgrade once again and facing the same issues. Playmaker disappear from project.

I have only one same error in 3 places
Code: [Select]
Assets/PlayMaker Utils/PlayMakerUtils_FsmVar.cs(372,33): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity.
indie developer of multiplayer adult fighting
http://nakedfighter3d.com

nFighter

  • Beta Group
  • Full Member
  • *
  • Posts: 138
    • View Profile
    • multiplayer adult fighting
Re: Correct way to upgrade from 2017 to 2018
« Reply #5 on: February 09, 2019, 06:21:41 AM »
I check the forum an as I understand the problem is a playmaker utils that are not updated. But I can't update anything cos playmaker disappear from menu... So my question are still the same: what are the correct order of moves to update from 2017 to 2018 if my project use a ArrayMaker and other ecosystem stuff?
indie developer of multiplayer adult fighting
http://nakedfighter3d.com

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 4360
    • View Profile
    • jinxtergames
Re: Correct way to upgrade from 2017 to 2018
« Reply #6 on: February 10, 2019, 09:54:43 AM »
Hi.
You can try to update PlayMaker Utils 1st.

You can find it on the Ecosystem.

or download it directly from github :

and install on the upgraded version.
FOR HIRE:Playmaker/C#

Playmaker Samples <-------------> Easy Exporter <---------------------> TPA Actions

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14316
  • Official Playmaker Support
    • View Profile
Re: Correct way to upgrade from 2017 to 2018
« Reply #7 on: February 10, 2019, 10:55:10 PM »
Hi,

 also, let me know what you got from the ecosystem that had its playmaker utils not updated yet, I need to republish it.

To solve this right now, simply get the playmaker utils item from the ecosystem.

 Bye,

 Jean

nFighter

  • Beta Group
  • Full Member
  • *
  • Posts: 138
    • View Profile
    • multiplayer adult fighting
Re: Correct way to upgrade from 2017 to 2018
« Reply #8 on: February 13, 2019, 08:48:29 AM »
I give up. My project is too big. I spent 2 hours loading and unloading it, but still can't manage to run it on 2018.
On a bright side, updating Ecosystem, Utils from github, ArrayMaker & Playmaker itself on 2017 seems to work well. At least I saw a Playmaker menu on 2018 after update.
Still got dozens of errors related to P-VUE.
indie developer of multiplayer adult fighting
http://nakedfighter3d.com

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14316
  • Official Playmaker Support
    • View Profile
Re: Correct way to upgrade from 2017 to 2018
« Reply #9 on: February 13, 2019, 11:06:37 PM »
Hi,

 On big project, I don't update to major releases, I stay at the XX level, so if I have a 2017 project, I'll stick to it. get the LTS version and go for it.

just to make sure, your struggle is is not playmaker related anymore right? else let us know, upgrading to 2018 must work for playmaker projects.

Bye,

 Jean