playMaker

Author Topic: playMaker archive somewhere - looking for version 1.8.1  (Read 656 times)

Nougatti

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
playMaker archive somewhere - looking for version 1.8.1
« on: January 08, 2019, 03:08:55 AM »
Hi,

I am new to playMaker and I need an older version, 1.8.1.
Is there an archive available where I can download this version?

Regards
« Last Edit: January 08, 2019, 03:10:29 AM by Nougatti »

Kaiowaios

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
Re: playMaker archive somewhere - looking for version 1.8.1
« Reply #1 on: January 08, 2019, 01:32:53 PM »
Hi,

I don't think there are options to download older versions.
I also once thought I needed an older version.

Are you getting compile errors when you attempt to play the game? If so any problems you have could be related to a single custom action.

Just some personal experience.

Best to you

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3631
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: playMaker archive somewhere - looking for version 1.8.1
« Reply #2 on: January 08, 2019, 01:49:43 PM »
If you join the PlayMaker Beta Group you have access to an archive of old versions.

However, it really is better to work with the newest version. It will have the best compatibility with newer versions of Unity etc.

Can you give some details about why you need the older version?

Nougatti

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: playMaker archive somewhere - looking for version 1.8.1
« Reply #3 on: January 08, 2019, 11:10:25 PM »
Thanks for the response.

I am preparing a small demo of Salesforce integration with Unity.
There is a (somewhat older) tutorial on Salesforce that relies on Unity 5.5.3 with PlayMaker 1.8.1. (https://trailhead.salesforce.com/content/learn/projects/workshop-virtual-reality)

When I used the latest version of PlayMaker I get several errors that I suspect are version related. (Assets/PlayMaker Utils/Wizards/LinkerWizard/LinkerData.cs(18,7): error CS0246: The type or namespace name `PlayMaker' could not be found. Are you missing an assembly reference?)

The idea is to develop a more interactive integration using HTC Vive. But I want to show both implementations, one on cardboard and one, more advanced, on Vive.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3631
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: playMaker archive somewhere - looking for version 1.8.1
« Reply #4 on: January 09, 2019, 02:03:55 PM »
Did you install PlayMaker after importing?
https://hutonggames.fogbugz.com/f/page?W11

Nougatti

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: playMaker archive somewhere - looking for version 1.8.1
« Reply #5 on: January 10, 2019, 12:41:49 AM »
Hi Alex,

Thanks for the reply.
Yes, I installed after importing.

I started from scratch in a new Unity 5.5.3 project after a reboot. Using the download manager form the old Asset store I downloaded the package again but it keeps coming back with version 1.9.0.p5 and also generating the same errors as before.

Is there a reason why you don't provide older versions in an archive?
Because of this issue I had to cancel the demo and will be looking into other options.

Regards



Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3631
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: playMaker archive somewhere - looking for version 1.8.1
« Reply #6 on: January 10, 2019, 02:59:42 PM »
There's not a huge demand for older versions, but we do provide access through our beta group. Sorry I didn't realize you had a deadline! I went to the salesforce page to try and follow along to see where it might break in newer versions of Unity/Playmaker but it's a pretty hefty tutorial. LinkerWizard is not part of the standard install, so I was trying to see if it was required - did it tell you to install it?

Generally, add-ons and ecosystem scripts are updated to work with the latest version of PlayMaker. Getting older versions compatible with specific older versions of PlayMaker would be quite difficult! If LinkerWizard is the only issue you can do what that tool does manually (search for LinkerWizard on the forums).

If you still need access to an older version PM me about beta group access.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14400
  • Official Playmaker Support
    • View Profile
Re: playMaker archive somewhere - looking for version 1.8.1
« Reply #7 on: January 11, 2019, 12:16:33 AM »
Hi,

 simply delete the Linkerwizard, it's not needed if you are not developing for mobile and using actions that relies on Reflections.

Bye,

 Jean