playMaker

Author Topic: Event proxy addon tool not sending animation event.[SOLVED]  (Read 1299 times)

RICK

  • Playmaker Newbie
  • *
  • Posts: 39
    • View Profile
Event proxy addon tool not sending animation event.[SOLVED]
« on: April 02, 2019, 05:54:25 PM »
Hi,
I haven't learned how to code yet, thats why I purchased Playmaker. I've been using it for about a year now and been able to figure out problems I came across While using it for what I needed to do. I recently came across the add-on, Event  Proxy.
The following are the steps I took following a video tutorial.
          Attached the proxy event script to my animator game object.
          Attached animation event FSM to my animator game object.
          Set up Playmaker global events.
          Original animations were copied and animation events marked.
          The proxy event script settings as follows:
                 Event target is owner, which is my animator game object.
                FSM event is the global event I set up in the animation event FSM.

When I test the message using the test function in the event proxy script in the Inspector tab, the event is received by the animation event FSM. when I play the animation, the event is not being triggered. Did I miss
something ? I looked through the forum and Google but could not find anything to help me.

Thanks,

Rick
 
« Last Edit: April 04, 2019, 03:22:50 AM by jeanfabre »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15494
  • Official Playmaker Support
    • View Profile
Re: Event proxy addon tool not sending animation event.
« Reply #1 on: April 03, 2019, 02:06:48 AM »
Hi,

- did you setup the animation event in your animation timeline, and what's its name?

Bye,

 Jean

RICK

  • Playmaker Newbie
  • *
  • Posts: 39
    • View Profile
Re: Event proxy addon tool not sending animation event.
« Reply #2 on: April 03, 2019, 02:10:26 PM »
Hi Jean,

Thanks for the quick response. I figured it out. When I made a copy of my animation to mark my animation event, I changed the speed of the animation in
mecanim. For some reason the event will not trigger if I do that. I repeated the problem multiple times by changing the speed and had make a new copy of the animation and keep the speed the same as the original clip for my events to work.

Thanks,

RICK

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 6395
    • View Profile
    • jinxtergames
Re: Event proxy addon tool not sending animation event.
« Reply #3 on: April 03, 2019, 05:30:42 PM »
Hi.
I had some issues before also with this, and the reason was that the animation actually did not reach the end where my event was

I had to set it 1 frame earlier and make sure anim should run till end and not stopped by other transitions
Ecosystem might not work at the moment
here are direct Github Links to the custom actions :
https://github.com/PlayMakerEcosystem
https://github.com/jeanfabre


Join the PlayMaker Discord Channel!

Tyricores

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
Re: Event proxy addon tool not sending animation event.[SOLVED]
« Reply #4 on: August 24, 2021, 06:52:33 AM »
djaydino, I recently had a problem similar to yours. It was the same, by my event the animation did not come to the end. I followed your action and set it 1 frame earlier. Bingo, it worked, the animation continued to the end and was not affected by other transitions. I'm happy, but my friend is still sad. He's having problems all the time that he's been dealing with for a long time. Recently he was playing an animation and the event wouldn't start. We solved the problem for a long time until we found a way with https://proxycrawl.com/scraping-api-avoid-captchas-blocks
« Last Edit: August 26, 2021, 10:51:54 AM by Tyricores »