playMaker

Author Topic: Moving states inside prefabs send them flying to the lower corner of the graph  (Read 975 times)

Hen7

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Hey
I have a few playmaker prefabs that I'm using, however, when I'm dragging states with the mouse they suddenly jump and move super far away from the rest of the fsm.

See pic:
https://www.dropbox.com/s/ke6t8lz16ihku2n/playmaker.JPG

Marked in red is where currently the state is, and the rest of the FSM.
This is extremely frustrating to work with, and usually I have to restart unity for it to get fixed and be able to work on my prefab, it usually starts happening again within minutes.

I'm using playmaker 1.9.0 on unity 2019.1.8. f1
Any help?

p0d04Va

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Try and uncheck auto save for prefab.

Clockwork

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
After updating playmaker to the latest version, I've started having this issue also.  I've seen the same bug in the past, perhaps a year or so ago, but it was fixed until now.

Chex

  • Playmaker Newbie
  • *
  • Posts: 1
    • View Profile
I'm having the exact same issue as the original poster.  TY for any help with this.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15219
  • Official Playmaker Support
    • View Profile
Hi,

 I'll bump Alex on this, it was fixed previously, so there may be a regression here.

bye,

Jean

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3637
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Can anyone still seeing this post the full Playmaker and Unity version info found in the About windows. Also if you can submit a bug report it will give us more system info to help us track down the issue. Thanks!