playMaker

Author Topic: Templates - [Click to Edit Template] Not Responding...  (Read 1995 times)

kromenak

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
Templates - [Click to Edit Template] Not Responding...
« on: February 21, 2013, 06:12:25 PM »
Hello, quick question about templates - I found one tutorial video on them, but not much more.  I like the idea of using templates to keep a collection of related state machines synced up independent of whether they share a prefab or not. 

However, I've noticed that when I assign a template to a state machine, most of the PlayMaker editor becomes grayed out.  Additionally, it says [Click to Edit Template] in the center of the editor, but clicking doesn't cause anything to happen.  There were a couple times it let me edit after clicking, but I'm not sure what I'm doing differently to make that work.

Has anyone run into similar issues?  Maybe I'm not totally understanding how saving/loading templates works, but I could only find one two minute video tutorial on the subject, which only covered saving a template - not loading it later.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3883
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Templates - [Click to Edit Template] Not Responding...
« Reply #1 on: February 21, 2013, 06:14:22 PM »
Are you using 1.5.2?

kromenak

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
Re: Templates - [Click to Edit Template] Not Responding...
« Reply #2 on: February 21, 2013, 06:50:15 PM »
I think so, 1.5.2.f1.  I'm in Unity 4.0.1f2 as well.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3883
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Templates - [Click to Edit Template] Not Responding...
« Reply #3 on: February 22, 2013, 07:36:04 PM »
1.5.3 fixes a couple of template bugs in Unity 4.0.1.

It's submitted to the asset store, waiting review...

kromenak

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
Re: Templates - [Click to Edit Template] Not Responding...
« Reply #4 on: February 25, 2013, 05:48:37 PM »
Awesome, I'll report back after the update goes live and I have some time to test it.  Thanks!