playMaker

Author Topic: Playmaker not playing very short animation clips [FIXED]  (Read 4571 times)

Teknopathetic

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
Playmaker not playing very short animation clips [FIXED]
« on: June 27, 2011, 12:57:14 PM »
Hi there, I'm noticing Playmaker having trouble playing really short animation clips made in the Unity animation editor.  I have a scene with a capsule and a cube parented to the capsule with an FSM on the capsule that has just a starting idle state, then on pressing a button transitions to a second state where an animation of the cube moving is played and then on completion goes back to the initial state.  When I have the animation clip shorter than 0:20, the animation won't play at all and the FSM essentially hangs on the second state, because it doesn't finish and fire the event to go back to the first.  If I change the animation so that it is 0:20 or longer, the animation plays properly and triggers the event to go back to the first state.  The shorter animation does play properly if I play it through code, just not when I attempt to play it with a Playmaker action.

Edit:  To clarify, this does not seem to change no matter what wrap mode you select.  Also, if you the animation is longer than 0:20 but you increase the speed at which it plays with the animation settings action, it still won't play.
« Last Edit: October 06, 2011, 01:04:14 PM by alexchouls »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14692
  • Official Playmaker Support
    • View Profile
Re: Playmaker not playing very short animation clips
« Reply #1 on: June 28, 2011, 02:16:51 AM »
Hi,

 Make sure you test this in a published version. The editor slows down and affect the performances quit a lot.

Or test with nothing in your layout but the game view. That also could unleash more perfs.

Bye,

 Jean

justifun

  • 1.2 Beta
  • Full Member
  • *
  • Posts: 228
    • View Profile
Re: Playmaker not playing very short animation clips
« Reply #2 on: June 28, 2011, 02:07:27 PM »
Make sure your animation blend time is set to a lesser number than the length of your animation clip, or else its going to try and blend for a longer time than the clip, and it will appear like its not even playing or give you errors like you are describing.

give the play animation action a value of 0.0 for the blend time and it should work fine.


Teknopathetic

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
Re: Playmaker not playing very short animation clips
« Reply #3 on: June 28, 2011, 06:09:44 PM »
Ah, yeah, the blend time was it.  Thanks for the help, guys.